classification
Title: make install hangs on macOS when there is an existing Python app
Type: behavior Stage: resolved
Components: Installation, macOS Versions: Python 3.6
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: achimnol, ned.deily, ronaldoussoren
Priority: normal Keywords:

Created on 2018-03-29 08:47 by achimnol, last changed 2018-03-29 14:47 by achimnol. This issue is now closed.

Messages (4)
msg314639 - (view) Author: Joongi Kim (achimnol) * Date: 2018-03-29 08:47
I have installed Python 3.6.4 for macOS by downloading from the official site (www.python.org) and then tried installing 3.6.5 using pyenv.

Then the installation process hangs here:

https://user-images.githubusercontent.com/555156/38078784-57e44462-3378-11e8-8011-9579afc3c811.png

There is a 2-years old issue in pyenv (https://github.com/pyenv/pyenv/issues/512) but this may have to be fixed from here.
msg314640 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-03-29 09:02
Sorry, we can't do much about pyenv issues, suggest you pursue with that project.  If pyenv uses the python.org installers, there is an installer option to avoid installing into /Applications.  If pyenv does its own Python framework build, it can install the framework and the Applications directory into any directory using the --enable-framework=/path/to/directory option of ./configure.
msg314641 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-03-29 09:10
P.S. There *is* an old languishing issue, Issue11486, to add an option to configure to have framework builds not try to install into /Applications.  The patch there would need to be updated and turned into a PR for review.
msg314653 - (view) Author: Joongi Kim (achimnol) * Date: 2018-03-29 14:47
I found that the reason was my Python 3.6.4 installed via the official-installer has the permission of "root:wheel" and pyenv is running in my plain user privilege. Using chown command to change the permissions to "joongi:admin" and retrying worked.

What I'm curious now is: why didn't "rm -r /Application/Python\ 3.6" command explicitly display the permission error and just the whole installation process hanged up?
History
Date User Action Args
2018-03-29 14:47:17achimnolsetmessages: + msg314653
2018-03-29 09:10:37ned.deilysetmessages: + msg314641
2018-03-29 09:02:50ned.deilysetstatus: open -> closed
resolution: third party
messages: + msg314640

stage: resolved
2018-03-29 08:47:59achimnolcreate