classification
Title: Use super().method instead in Logging
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.8
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: vinay.sajip Nosy List: madsjensen, rhettinger, vinay.sajip
Priority: normal Keywords: patch

Created on 2018-03-27 11:22 by madsjensen, last changed 2018-07-11 17:06 by rhettinger. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 5799 madsjensen, 2018-03-27 17:15
Messages (3)
msg314517 - (view) Author: Mads Jensen (madsjensen) * Date: 2018-03-27 11:22
There are lots of legacy calls in the form of ClassName.method, which should be replaced with super().method. This is an issue in many modules; I've been asked to create a report for each module that the PR touches.
msg321475 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2018-07-11 15:06
See the comments on bpo-31853. I agree with the consensus there that these changes aren't worth doing:

msg314518
msg314520
msg314521

So, I propose to close this as "not a bug" which in this context means "not an enhancement that's worth doing".
msg321488 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2018-07-11 17:06
I agree that this shouldn't be done for logging and that likely it shouldn't be done for most modules.
History
Date User Action Args
2018-07-11 17:06:36rhettingersetstatus: open -> closed

nosy: + rhettinger
messages: + msg321488

resolution: rejected
stage: patch review -> resolved
2018-07-11 15:06:04vinay.sajipsetmessages: + msg321475
2018-03-27 19:29:07rhettingersetassignee: vinay.sajip
2018-03-27 17:15:12madsjensensetkeywords: + patch
stage: patch review
pull_requests: + pull_request5999
2018-03-27 11:38:24serhiy.storchakasetnosy: + vinay.sajip

type: enhancement
versions: + Python 3.8
2018-03-27 11:22:48madsjensencreate