classification
Title: Use list comprehension in timeit module instead of loop with append
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Windson Yang, dstufft, eric.araujo, serhiy.storchaka
Priority: normal Keywords: patch

Created on 2018-03-27 08:05 by Windson Yang, last changed 2018-03-30 19:04 by eric.araujo. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 6269 closed python-dev, 2018-03-27 08:08
Messages (2)
msg314504 - (view) Author: Windson Yang (Windson Yang) * Date: 2018-03-27 08:05
https://github.com/python/cpython/blob/master/Lib/timeit.py#L202

use a list comprehension instead
msg314529 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-03-27 15:10
We usually do not do such kind of changes due to the risk of introducing new bugs (as your PR demonstrated). Only when other changes are applied to the module, the surrounded code can be cleaned up. Or the maintainer of the module can do this if he decided that it is a time for modernization.
History
Date User Action Args
2018-03-30 19:04:38eric.araujosetstatus: open -> closed
type: behavior ->
resolution: not a bug
components: + Library (Lib), - Distutils
stage: patch review -> resolved
2018-03-27 15:10:39serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg314529
2018-03-27 15:02:40pablogsalsettitle: clean code -> Use list comprehension in timeit module instead of loop with append
2018-03-27 08:08:10python-devsetkeywords: + patch
stage: patch review
pull_requests: + pull_request5994
2018-03-27 08:05:41Windson Yangcreate