classification
Title: unaligned accesses in siphash24() lead to crashes on sparc
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.8, Python 3.7, Python 3.6, Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: pyhash's siphash24 assumes alignment of the data pointer
View: 28055
Assigned To: Nosy List: Dakon, Jeffrey.Walton, serhiy.storchaka
Priority: normal Keywords:

Created on 2018-03-26 16:29 by Dakon, last changed 2018-07-21 12:24 by Jeffrey.Walton. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 6123 Dakon, 2018-03-26 16:29
Messages (2)
msg314464 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-03-26 16:52
Actually this looks like a duplicate of issue28055.
msg322096 - (view) Author: Jeffrey Walton (Jeffrey.Walton) * Date: 2018-07-21 12:24
I know this is a bit late but I wanted to share...

OpenCSW has a build farm with Solaris machines and Sparc hardware. The farm provides x86 and Sparc machines with Solaris 9 through 11.

I believe OpenCSW operates in the same spirit as GCC compile farm. They welcome open source developers and upstream maintainers to help ensure packages build and run on Solaris machines.

You can read about it at
https://www.opencsw.org/extend-it/signup/to-upstream-maintainers/ .

If Python is performing memory access patterns as discussed in the report then it would probably benefit the project to test on a Sparc machine with Solaris 11.
History
Date User Action Args
2018-07-21 12:24:56Jeffrey.Waltonsetnosy: + Jeffrey.Walton
messages: + msg322096
2018-03-26 16:52:24serhiy.storchakasetstatus: open -> closed

superseder: pyhash's siphash24 assumes alignment of the data pointer

nosy: + serhiy.storchaka
messages: + msg314464
resolution: duplicate
stage: resolved
2018-03-26 16:29:47Dakoncreate