classification
Title: Some examples in documentation section 4.7.2 are incorrect
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.8, Python 3.7, Python 3.6, Python 3.5, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: abarry, docs@python, stephenwp
Priority: normal Keywords:

Created on 2018-03-09 15:27 by stephenwp, last changed 2018-03-09 15:35 by abarry. This issue is now closed.

Messages (2)
msg313485 - (view) Author: Stephen Wille Padnos (stephenwp) Date: 2018-03-09 15:27
Section 4.7.2 of the documentation, "Keyword Arguments", has several examples of valid calls to the sample function parrot.

The function definition is:
def parrot(voltage, state='a stiff', action='voom', type='Norwegian Blue'):

The last two calls in the valid samples are actually not valid, since they are missing the required "voltage" parameter.
parrot('a million', 'bereft of life', 'jump')         # 3 positional arguments
parrot('a thousand', state='pushing up the daisies')  # 1 positional, 1 keyword

They should be changed to include a value for voltage, along with a change to the comment:
parrot(1000, 'a million', 'bereft of life', 'jump')         # 4 positional arguments
parrot(1000, 'a thousand', state='pushing up the daisies')  # 2 positional, 1 keyword

This issue is present in all currently available versions of the documentation: 2.7; 3.5; 3.6.4; pre (3.7); and dev (3.8).
msg313486 - (view) Author: Anilyka Barry (abarry) * (Python triager) Date: 2018-03-09 15:35
The documentation is correct. The first argument in both of those cases is a str, which may not be what you were expecting, but the calls are still valid.
History
Date User Action Args
2018-03-09 15:35:26abarrysetstatus: open -> closed

nosy: + abarry
messages: + msg313486

resolution: not a bug
stage: resolved
2018-03-09 15:27:32stephenwpcreate