classification
Title: Message parsing fails where it has incompele headers
Type: behavior Stage: resolved
Components: email Versions: Python 3.6, Python 3.4, Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Email parser creates a message object that can't be flattened
View: 27321
Assigned To: Nosy List: barry, martin.panter, r.david.murray, reb00ter
Priority: normal Keywords: patch

Created on 2018-01-23 08:31 by reb00ter, last changed 2018-01-23 17:34 by r.david.murray. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 5267 closed reb00ter, 2018-01-23 08:32
Messages (3)
msg310485 - (view) Author: Maxim Barabanov (reb00ter) * Date: 2018-01-23 08:31
If email message dont have a content-transfer-encoding or content-type header, function write in generator.py crashes
msg310492 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2018-01-23 10:28
Looks like a dupe of Issue 27321
msg310515 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2018-01-23 17:34
Yes, it is.
History
Date User Action Args
2018-01-23 17:34:20r.david.murraysetstatus: open -> closed
type: crash -> behavior
messages: + msg310515

stage: patch review -> resolved
2018-01-23 10:28:23martin.pantersetnosy: + martin.panter
messages: + msg310492
resolution: duplicate

superseder: Email parser creates a message object that can't be flattened
2018-01-23 08:32:00reb00tersetkeywords: + patch
stage: patch review
pull_requests: + pull_request5125
2018-01-23 08:31:16reb00tercreate