classification
Title: Bad detection of clang
Type: Stage: resolved
Components: Distutils Versions: Python 3.8, Python 3.7, Python 3.6, Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: bapt, dstufft, eric.araujo, steve.dower, vstinner
Priority: normal Keywords:

Created on 2018-01-19 13:15 by bapt, last changed 2021-02-03 18:19 by steve.dower. This issue is now closed.

Messages (3)
msg310275 - (view) Author: bapt (bapt) Date: 2018-01-19 13:15
When building modules and trying to set the proper linker flags for the library runtime path, the detection of the compiler is wrong. the issue: 
https://bugs.python.org/issue20767 was showing the issue and imho badly fixed.

Clang behave like gcc regarding how it passes flags to the linker: -Wl,... so clang and gcc should be treated exactly the same way and no specific code should be added for FreeBSD

Here https://github.com/python/cpython/blob/master/Lib/distutils/unixccompiler.py#L237, it should accept both clang and gcc,

This block https://github.com/python/cpython/blob/master/Lib/distutils/unixccompiler.py#L230 should be removed

The issue is not only on FreeBSD but on any system which compiler is clang. side note, the detection of gcc looks at first glance wrong, as on many system gcc is installed as cc sometime.
msg310358 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2018-01-20 19:28
> https://bugs.python.org/issue20767 was showing the issue and imho badly fixed.

You do realize that the fix was proposed by FreeBSD people and that the upstream Clang issue is still open?
msg386329 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-02-03 18:19
Distutils is now deprecated (see PEP 632) and all tagged issues are being closed. From now until removal, only release blocking issues will be considered for distutils.

If this issue does not relate to distutils, please remove the component and reopen it. If you believe it still requires a fix, most likely the issue should be re-reported at https://github.com/pypa/setuptools
History
Date User Action Args
2021-02-03 18:19:23steve.dowersetstatus: open -> closed

nosy: + steve.dower
messages: + msg386329

resolution: out of date
stage: resolved
2018-01-22 18:25:54skrahsetnosy: - skrah
2018-01-20 19:28:42skrahsetnosy: + skrah
messages: + msg310358
2018-01-19 13:16:33baptsetnosy: + vstinner
2018-01-19 13:15:32baptcreate