classification
Title: Not able to run Python 3.6 on Windows
Type: crash Stage: resolved
Components: Windows Versions: Python 3.6
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: Kiran, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2018-01-16 09:30 by Kiran, last changed 2018-02-19 21:28 by steve.dower. This issue is now closed.

Files
File name Uploaded Description Edit
Python.jpg Kiran, 2018-01-16 09:30
Messages (3)
msg310062 - (view) Author: Kiran (Kiran) Date: 2018-01-16 09:30
Hello,

I am new to Python and installed python3 recently and when I try to open IDLE, Iam getting the error attached.

Please let me know how to resolve it.

Thanks.
msg310182 - (view) Author: Kiran (Kiran) Date: 2018-01-17 14:54
Hi,

Can someone help me to resolve the issue or let me know the cause of this error.

Thanks in advance.
msg310215 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2018-01-17 23:17
Looks like you have a prerelease version of the CRT on your machine. Try finding and installing the latest Visual C++ 2017 Redistributables from Microsoft.

A newer version would have been installed by Python but since it wasn't I assume you have some other program on your PATH that has included a (not quite) private copy of ucrtbase.dll. If you can find and update or uninstall that program, and then reinstall Python it should resolve it.
History
Date User Action Args
2018-02-19 21:28:57steve.dowersetstatus: open -> closed
resolution: works for me
stage: resolved
2018-01-19 20:18:51terry.reedysettitle: Not able to open Python IDLE -> Not able to run Python 3.6 on Windows
2018-01-17 23:17:27steve.dowersetmessages: + msg310215
2018-01-17 14:54:33Kiransetmessages: + msg310182
2018-01-16 09:30:28Kirancreate