classification
Title: nav menu jitter in old documentation
Type: behavior Stage: resolved
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Docs page's sidebar vibrates on mouse wheel scroll on Chrome.
View: 24712
Assigned To: docs@python Nosy List: Joseph Hendrey, docs@python, martin.panter, mdk
Priority: normal Keywords:

Created on 2017-12-20 23:00 by Joseph Hendrey, last changed 2019-05-07 21:23 by mdk. This issue is now closed.

Files
File name Uploaded Description Edit
screenshot.JPG Joseph Hendrey, 2017-12-20 23:00 screenshot of fix
Messages (3)
msg308834 - (view) Author: Joseph Hendrey (Joseph Hendrey) Date: 2017-12-20 23:00
The sidebar navigation menu jitters when scrolling on the 2.7 documentation pages (at least in Chrome).

A seemingly unrelated issue is that the collapse symbol '<<' is a fixed distance from the top of the page rather than staying in the centre (height-wise) of the screen (it should always be visible).

It seems it has been fixed for newer documentation, but since the fix is so simple it would be nice to fix it for the old documentation too. Setting the position property of the span element seems to fix both issues for me (see attached screenshot)
msg316496 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2018-05-14 09:21
Maybe related to Issue 24712?
msg341829 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2019-05-07 21:23
I'm closing this as a duplicate of https://bugs.python.org/issue24712, for which I opened a pull request.
History
Date User Action Args
2019-05-07 21:23:06mdksetstatus: open -> closed
superseder: Docs page's sidebar vibrates on mouse wheel scroll on Chrome.
messages: + msg341829

resolution: duplicate
stage: resolved
2018-05-14 09:21:55martin.pantersetnosy: + martin.panter
messages: + msg316496
2017-12-21 15:28:39mdksetnosy: + mdk
2017-12-20 23:00:52Joseph Hendreycreate