classification
Title: test.pythoninfo does not print the cross-built sysconfig data
Type: behavior Stage: resolved
Components: Cross-Build Versions: Python 3.7, Python 3.6, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Alex.Willmer, vstinner, xdegaye
Priority: normal Keywords: patch

Created on 2017-12-03 13:28 by xdegaye, last changed 2017-12-08 16:14 by xdegaye. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 4687 closed xdegaye, 2017-12-03 13:38
Messages (5)
msg307510 - (view) Author: Xavier de Gaye (xdegaye) * (Python triager) Date: 2017-12-03 13:28
When cross-compiling the only useful information printed by pythoninfo is the cross-built sysconfig data since everything else is related to the native python process used during the cross-build.

Currently pythoninfo prints the native sysconfig data instead.
msg307573 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-12-04 15:50
I'm not sure of the purpose of this change. You can please elaborate on you use case?

You use cross-compilation, ok. But why do you want to run test.pythoninfo on the computer building Python, rather than the computer running tests?

The purpose of test.pythoninfo is to dump informations on tests run by "./python -m test". I wrote it for buildbots.

If your use case is to have an Android buildbot worker, test.pythoninfo would be run on Android, no?
msg307578 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-12-04 16:58
"make pythoninfo" is an alias for ./python -m test.pythoninfo. I added to support Python compiled in shared mode (./configure --enable-shared) and macOS which requires ./python.exe.

Obviously, for a specific buildbot or specific script, you are free to run directly ./python -m test.pythoninfo, rather than running "make pythoninfo" ;-)
msg307579 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-12-04 16:58
See also bpo-32210: Add the versions of the Android SDK and NDK to test.pythoninfo.
msg307587 - (view) Author: Xavier de Gaye (xdegaye) * (Python triager) Date: 2017-12-04 17:56
I may have misunderstood the scope of pythoninfo. On Android the readline or sqlite versions are known at build time since they have to be built at that time, but much more useful information can be obtained (or will be obtained) from python running on the device or the emulator.

For the NDK and SDK versions (issue 32210), these can be printed by the 'all' target for the NDK and by one of the emulator targets for the SDK.

This means that both this issue and #32210 may be closed as wont fix.
History
Date User Action Args
2017-12-09 15:42:06xdegayelinkissue26865 dependencies
2017-12-08 16:14:58xdegayesetresolution: wont fix -> not a bug
2017-12-05 10:52:33xdegayesetstatus: open -> closed
resolution: wont fix
stage: patch review -> resolved
2017-12-04 17:56:06xdegayesetmessages: + msg307587
2017-12-04 16:58:44vstinnersetmessages: + msg307579
2017-12-04 16:58:28vstinnersetmessages: + msg307578
2017-12-04 15:50:07vstinnersetmessages: + msg307573
2017-12-03 13:38:42xdegayesetkeywords: + patch
stage: needs patch -> patch review
pull_requests: + pull_request4600
2017-12-03 13:28:10xdegayecreate