classification
Title: android: test_faulthandler fails also on API 24
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: vstinner, xdegaye
Priority: normal Keywords: patch

Created on 2017-11-26 09:58 by xdegaye, last changed 2017-11-29 10:45 by xdegaye. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 4604 merged xdegaye, 2017-11-28 10:15
Messages (3)
msg306999 - (view) Author: Xavier de Gaye (xdegaye) * (Python triager) Date: 2017-11-26 09:58
Issue 26934 skipped some tests of test_faulthandler on Android API < 24 to fix the problem that python does not crash upon _sigsegv(). But the same problem occurs on API 24 except randomly, you need to run test_faulthandler many times before reproducing it, see below few results in that case.

I propose to skip those tests whatever the value of the Android API level.
In that case the test.support.requires_android_level decorator is not used anymore and should be removed.


1 test failed:
  test_faulthandler

    generic_x86_64:/data/local/tmp/python $ python -m test test_faulthandler
    Run tests sequentially
    0:00:00 [1/1] test_faulthandler
    test test_faulthandler failed -- Traceback (most recent call last):
      File "/sdcard/org.python/lib/python3.7/test/test_faulthandler.py", line 265, in test_enable_file
        filename=filename)
      File "/sdcard/org.python/lib/python3.7/test/test_faulthandler.py", line 114, in check_fatal_error
        self.check_error(code, line_number, fatal_error, **kw)
      File "/sdcard/org.python/lib/python3.7/test/test_faulthandler.py", line 107, in check_error
        output, exitcode = self.get_output(code, filename=filename, fd=fd)
      File "/sdcard/org.python/lib/python3.7/test/test_faulthandler.py", line 67, in get_output
        self.assertEqual(output, '')
    AssertionError: "sys:1: ResourceWarning: unclosed file <_[49 chars]c3'>" != ''
    - sys:1: ResourceWarning: unclosed file <_io.BufferedWriter name='/data/local/tmp/tmp17fv9xc3'>
    + 

======================================================================
FAIL: test_disable (test.test_faulthandler.FaultHandlerTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/sdcard/org.python/lib/python3.7/test/test_faulthandler.py", line 307, in test_disable
    self.assertNotEqual(exitcode, 0)
AssertionError: 0 == 0

======================================================================
FAIL: test_gil_released (test.test_faulthandler.FaultHandlerTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/sdcard/org.python/lib/python3.7/test/test_faulthandler.py", line 252, in test_gil_released
    'Segmentation fault')
  File "/sdcard/org.python/lib/python3.7/test/test_faulthandler.py", line 114, in check_fatal_error
    self.check_error(code, line_number, fatal_error, **kw)
  File "/sdcard/org.python/lib/python3.7/test/test_faulthandler.py", line 110, in check_error
    self.assertNotEqual(exitcode, 0)
AssertionError: 0 == 0
msg307047 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-11-27 11:01
> I propose to skip those tests whatever the value of the Android API level.

Works for me.
msg307218 - (view) Author: Xavier de Gaye (xdegaye) * (Python triager) Date: 2017-11-29 10:43
New changeset ef83806f5ec01f34f6cbf4ebb5752875b5961f7e by xdegaye in branch 'master':
bpo-32138: Skip on Android test_faulthandler tests that raise SIGSEGV (GH-4604)
https://github.com/python/cpython/commit/ef83806f5ec01f34f6cbf4ebb5752875b5961f7e
History
Date User Action Args
2017-12-09 15:42:06xdegayelinkissue26865 dependencies
2017-11-29 10:45:17xdegayesetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2017-11-29 10:43:25xdegayesetmessages: + msg307218
2017-11-28 10:15:48xdegayesetkeywords: + patch
stage: needs patch -> patch review
pull_requests: + pull_request4521
2017-11-27 11:01:29vstinnersetmessages: + msg307047
2017-11-26 09:58:59xdegayecreate