classification
Title: Re locale test fails after installing Python 3.6.3 on ubuntu 16.04
Type: behavior Stage: resolved
Components: Installation, Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder: test_re is failing when local is set for `en_IN`
View: 29571
Assigned To: Nosy List: sachin, serhiy.storchaka, vstinner, xtreak
Priority: normal Keywords:

Created on 2017-11-20 06:05 by sachin, last changed 2019-10-24 10:46 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
test.Screenshot from 2017-11-20 11-12-41.png sachin, 2017-11-20 06:05
Messages (4)
msg306529 - (view) Author: Sachin Pathave (sachin) * Date: 2017-11-20 06:05
test failed when I run command $make test
FAILED (failures=1, skipped=1)
test test_re failed
2 tests failed again:
    test_re test_venv
msg325337 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2018-09-14 09:30
Is it something specific to the environment? I tried the test on Ubuntu 16.04 on both master and on v3.6.3 with no errors. Maybe if you can execute the following code based on which the test is executed then it will be helpful to debug this.


import locale

foo, enc = locale.getlocale(locale.LC_CTYPE)
# Search non-ASCII letter
for i in range(128, 256):
    try:
        c = bytes([i]).decode(enc)
        sletter = c.lower()
        if sletter == c: continue
        bletter = sletter.encode(enc)
        if len(bletter) != 1: continue
        if bletter.decode(enc) != sletter: continue
        bpat = re.escape(bytes([i]))
        break
    except (UnicodeError, TypeError):
        pass
else:
    bletter = None
    bpat = b'A'
# Bytes patterns

print(bletter)
print(bpat)
print(foo)
print(enc)



Thanks
msg355306 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2019-10-24 09:09
Looking at the traceback in the screenshot this seems to be same as issue29571 happening on en_IN locale.
msg355324 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-10-24 10:46
Yeah, that's a duplicate of bpo-29571 which has been fixed by:

New changeset 279657bac2856039ba422c18a3d7f227b455e9d6 by Victor Stinner in branch '3.7':
[3.7] bpo-29571: Fix test_re.test_locale_flag() (GH-12178)
https://github.com/python/cpython/commit/279657bac2856039ba422c18a3d7f227b455e9d6

Python 3.7.3 and newer include my fix.
History
Date User Action Args
2019-10-24 10:46:11vstinnersetstatus: open -> closed
superseder: test_re is failing when local is set for `en_IN`
messages: + msg355324

resolution: fixed
stage: resolved
2019-10-24 09:09:30xtreaksetnosy: + vstinner
messages: + msg355306
2018-09-14 09:30:53xtreaksetnosy: + xtreak
messages: + msg325337
2017-11-24 19:31:55terry.reedysetnosy: + serhiy.storchaka

type: resource usage -> behavior
components: + Installation, Library (Lib), - 2to3 (2.x to 3.x conversion tool)
title: Error Installing Python 3.6.3 on ubuntu 16.04 -> Re locale test fails after installing Python 3.6.3 on ubuntu 16.04
2017-11-20 06:05:49sachincreate