classification
Title: time.sleep(n) interrupted by signal
Type: Stage: resolved
Components: Interpreter Core Versions: Python 3.4
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: Bogdan Popa, vstinner
Priority: normal Keywords:

Created on 2017-11-17 10:17 by Bogdan Popa, last changed 2017-11-17 10:56 by Bogdan Popa. This issue is now closed.

Messages (4)
msg306427 - (view) Author: Bogdan Popa (Bogdan Popa) Date: 2017-11-17 10:17
I ran into this while backporting some code from 3.6 to 3.5 and 3.4. The following piece of code prints one line every second, as expected, on 3.6 and 3.5, but it doesn't on 3.4. It looks like the signal is able to wake up the main thread from sleeping:

```
import time
import signal


def handle(signum, mask):
    print("received signal at", time.time())


signal.setitimer(signal.ITIMER_REAL, 1, 1)
signal.signal(signal.SIGALRM, handle)

for _ in range(2):
    now = time.time()
    delta = 1 - (time.time() - int(time.time()))
    time.sleep(delta)
    print(now, delta, time.time())
```

If I remove the timer, then everything works as expected on 3.4.

Here is some sample output from 3.6:

```
1510913832.4726589 0.5273411273956299 1510913833.000339
received signal at 1510913833.477888
1510913833.000449 0.9995510578155518 1510913834.000187
```

And some from 3.4:

```
1510913813.525479 0.4745209217071533 1510913814.004106
received signal at 1510913814.529313
1510913814.004233 0.9957659244537354 1510913814.529413
```
msg306428 - (view) Author: Bogdan Popa (Bogdan Popa) Date: 2017-11-17 10:24
I forgot to mention that I am on macOS Sierra (10.12.6) and I ran the code on Python 3.4.6, 3.5.3 and 3.6.3, respectively.
msg306429 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-11-17 10:31
I'm sorry but Python 3.4 doesn't accept bugfixes anymore. Same for Python 3.5.
https://devguide.python.org/#status-of-python-branches

> The following piece of code prints one line every second, as expected, on 3.6 and 3.5

Good, at least Python behaves as you want :-) Maybe it's an enhancement caused by the PEP 475.
msg306430 - (view) Author: Bogdan Popa (Bogdan Popa) Date: 2017-11-17 10:56
Fair enough. From reading PEP 475, it does look like that's what fixed it. Thanks Victor!
History
Date User Action Args
2017-11-17 10:56:37Bogdan Popasetstatus: open -> closed
resolution: wont fix
messages: + msg306430

stage: resolved
2017-11-17 10:31:13vstinnersetnosy: + vstinner
messages: + msg306429
2017-11-17 10:24:47Bogdan Popasetmessages: + msg306428
2017-11-17 10:17:40Bogdan Popacreate