classification
Title: Python 3.6.3 venv FAILURE
Type: Stage: resolved
Components: Versions: Python 3.6
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: cheryl.sabella, eric.araujo, ned.deily, nihon2000
Priority: normal Keywords:

Created on 2017-11-13 19:18 by nihon2000, last changed 2018-02-22 12:43 by cheryl.sabella. This issue is now closed.

Messages (4)
msg306165 - (view) Author: Larry Chen (nihon2000) Date: 2017-11-13 19:18
Upgraded from 3.6.1 to 3.6.3; but got an error when trying to create my virtual environment.

[larrchen@rslab239 Larry]$  /opt/python3.6.3/bin/python3.6 -m venv /u/larrchen/work2/SAN/Users/Larry/rslab239_myENV_363
Error: Command '['/u/larrchen/work2/SAN/Users/Larry/rslab239_myENV_363/bin/python3.6', '-Im', 'ensurepip', '--upgrade', '--default-pip']' returned non-zero exit status 1.

I can create a virtual env for 3.6.1 and 3.6.2 but not for 3.6.3.

This is a regression issue. 

Try this command. It fails every time.

python3.6 -m venv myEnv

Larry
msg306452 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2017-11-17 18:27
Can you find out the full error message from pip?
msg312518 - (view) Author: Cheryl Sabella (cheryl.sabella) * (Python triager) Date: 2018-02-22 00:18
Without any additional information, should this be closed as 'Works for Me'?
msg312519 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-02-22 00:20
> Without any additional information, should this be closed as 'Works for Me'?

Yes, please.
History
Date User Action Args
2018-02-22 12:43:10cheryl.sabellasetstatus: open -> closed
resolution: works for me
stage: resolved
2018-02-22 00:20:01ned.deilysetnosy: + ned.deily
messages: + msg312519
2018-02-22 00:18:37cheryl.sabellasetnosy: + cheryl.sabella
messages: + msg312518
2017-11-17 18:27:58eric.araujosetnosy: + eric.araujo
messages: + msg306452
2017-11-13 19:18:46nihon2000create