classification
Title: [Windows] PCbuild error: A numeric comparison was attempted
Type: compile error Stage: resolved
Components: Build, Windows Versions: Python 3.7, Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: steve.dower Nosy List: paul.moore, steve.dower, tim.golden, vstinner, zach.ware
Priority: normal Keywords: patch

Created on 2017-11-06 11:17 by vstinner, last changed 2017-11-07 22:55 by vstinner. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 4298 merged steve.dower, 2017-11-06 19:54
PR 4300 merged python-dev, 2017-11-06 20:52
Messages (6)
msg305631 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-11-06 11:17
http://buildbot.python.org/all/#/builders/58/builds/110

Build started 11/4/2017 7:30:21 PM.
Project "D:\cygwin\home\db3l\buildarea\3.x.bolen-windows7\build\PCbuild\pythoncore.vcxproj" on node 1 (KillPython target(s)).
D:\cygwin\home\db3l\buildarea\3.x.bolen-windows7\build\PCbuild\python.props(77,31): error MSB4086: A numeric comparison was attempted on "$(Registry:HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Microsoft SDKs\Windows\v10.0@ProductVersion)" that evaluates to "" instead of a number, in condition "$(Registry:HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Microsoft SDKs\Windows\v10.0@ProductVersion) >= '10.0.15063'". [D:\cygwin\home\db3l\buildarea\3.x.bolen-windows7\build\PCbuild\pythoncore.vcxproj]
Done Building Project "D:\cygwin\home\db3l\buildarea\3.x.bolen-windows7\build\PCbuild\pythoncore.vcxproj" (KillPython target(s)) -- FAILED.
Build FAILED.

It's likely a regression caused by one of these commits:

* 0d2a9088d16826343344b04461c8be44b4008710
* aed08562220974b5c67371b908f23caa1be07e38
msg305632 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-11-06 11:18
Compilation also failed on AMD64 Windows8 3.x:

http://buildbot.python.org/all/#/builders/32/builds/118
msg305633 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-11-06 11:18
Windows8 error:

D:\buildarea\3.x.bolen-windows8\build\PCbuild\python.props(76,31): error MSB4086: A numeric comparison was attempted on "$(Registry:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v10.0@ProductVersion)" that evaluates to "" instead of a number, in condition "$(Registry:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v10.0@ProductVersion) >= '10.0.15063'". [D:\buildarea\3.x.bolen-windows8\build\PCbuild\pythoncore.vcxproj]
msg305675 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2017-11-06 20:52
New changeset 30f4fa456ef626ad7a92759f492ec7a268f7af4e by Steve Dower in branch 'master':
bpo-31957: Fixes version detection. (#4298)
https://github.com/python/cpython/commit/30f4fa456ef626ad7a92759f492ec7a268f7af4e
msg305685 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2017-11-06 23:05
New changeset a6ffec2e88437ed4fecb10cb359cf2fb64781e9a by Steve Dower (Miss Islington (bot)) in branch '3.6':
[3.6] bpo-31957: Fixes version detection. (GH-4298) (#4300)
https://github.com/python/cpython/commit/a6ffec2e88437ed4fecb10cb359cf2fb64781e9a
msg305797 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-11-07 22:55
Thank you Steve for the quick fix!
History
Date User Action Args
2017-11-07 22:55:44vstinnersetstatus: open -> closed
resolution: fixed
messages: + msg305797

stage: patch review -> resolved
2017-11-06 23:05:00steve.dowersetmessages: + msg305685
2017-11-06 20:52:23python-devsetpull_requests: + pull_request4263
2017-11-06 20:52:11steve.dowersetmessages: + msg305675
2017-11-06 19:54:48steve.dowersetkeywords: + patch
stage: needs patch -> patch review
pull_requests: + pull_request4260
2017-11-06 19:39:22steve.dowersetassignee: steve.dower
stage: needs patch
type: compile error
versions: + Python 3.6
2017-11-06 11:18:34vstinnersetmessages: + msg305633
2017-11-06 11:18:11vstinnersetmessages: + msg305632
2017-11-06 11:17:26vstinnercreate