classification
Title: The elementtree.ElementTree Module doc is missing
Type: Stage:
Components: Documentation Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: benjamin.peterson, georg.brandl, gladstein
Priority: normal Keywords:

Created on 2008-06-23 23:13 by gladstein, last changed 2008-06-24 02:20 by gladstein. This issue is now closed.

Messages (5)
msg68659 - (view) Author: David Gladstein (gladstein) Date: 2008-06-23 23:13
The documentation from
http://www.effbot.org/zone/pythondoc-elementtree-ElementTree.htm
is missing. Without it the module is pretty much impossible to use,
unless you know about the effbot pages.
msg68660 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-23 23:41
What do you mean?
http://docs.python.org/lib/module-xml.etree.ElementTree.html
msg68661 - (view) Author: David Gladstein (gladstein) Date: 2008-06-24 02:05
an ElementTree instance holds a tree of Element instances which represents 
the XML tags. Element isn't documented.

in the effbot version, there's a page 
http://www.effbot.org/zone/pythondoc-elementtree-ElementTree.htm#elementtree.ElementTree._ElementInterface-class 
called
The elementtree.ElementTree Module
with a section

 The _ElementInterface Class

Despite the _ in the name, it's not an internal, it's the spec for the 
interface to the Element instances.

----- Original Message ----- 
From: "Benjamin Peterson" <report@bugs.python.org>
To: <david.gladstein@theorphanage.com>
Sent: Monday, June 23, 2008 4:41 PM
Subject: [issue3184] The elementtree.ElementTree Module doc is missing

Benjamin Peterson <musiccomposition@gmail.com> added the comment:

What do you mean?
http://docs.python.org/lib/module-xml.etree.ElementTree.html

----------
nosy: +benjamin.peterson

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue3184>
_______________________________________
msg68662 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-24 02:12
Ahh, but it is present in the new docs:
http://docs.python.org/dev/library/xml.etree.elementtree.html#the-element-interface.
msg68663 - (view) Author: David Gladstein (gladstein) Date: 2008-06-24 02:20
Excellent.

----- Original Message ----- 
From: "Benjamin Peterson" <report@bugs.python.org>
To: <david.gladstein@theorphanage.com>
Sent: Monday, June 23, 2008 7:12 PM
Subject: [issue3184] The elementtree.ElementTree Module doc is missing

Benjamin Peterson <musiccomposition@gmail.com> added the comment:

Ahh, but it is present in the new docs:
http://docs.python.org/dev/library/xml.etree.elementtree.html#the-element-interface.

_______________________________________
Python tracker <report@bugs.python.org>
<http://bugs.python.org/issue3184>
_______________________________________
History
Date User Action Args
2008-06-24 02:20:19gladsteinsetmessages: + msg68663
2008-06-24 02:15:38benjamin.petersonsetstatus: open -> closed
resolution: not a bug
2008-06-24 02:12:48benjamin.petersonsetmessages: + msg68662
2008-06-24 02:05:38gladsteinsetmessages: + msg68661
2008-06-23 23:41:13benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg68660
2008-06-23 23:13:41gladsteincreate