classification
Title: Lib/site.py: method `abs_paths` is not documented
Type: Stage: resolved
Components: Tests Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: eric.araujo, lielfr, mdk
Priority: normal Keywords:

Created on 2017-10-09 18:06 by lielfr, last changed 2017-10-16 17:53 by eric.araujo. This issue is now closed.

Messages (3)
msg303998 - (view) Author: Julien Palard (mdk) * Date: 2017-10-09 20:35
Hi, thanks for reporting.

This method has been renamed in https://github.com/python/cpython/commit/28a691b7fdde1b8abafa4c4a5025e6bfa44f48b9 and is only used in Lib/site.py (currently in main()).

The function has a docstring, so:

  Help on function abs_paths in module site:

  abs_paths()
      Set all module __file__ and __cached__ attributes to an absolute path


Is this function usefull for you outside of site.py?
msg304066 - (view) Author: Liel Fridman (lielfr) * Date: 2017-10-10 18:33
No, I've just tried to find something to work on as a first contribution.
msg304478 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2017-10-16 17:53
Thanks for wanting to help!  This function is not meant to be public, which explains why it’s not documented.  Please see the devguide and the core-mentorship mailing list to find ways to contribute!
History
Date User Action Args
2017-10-16 17:53:58eric.araujosetstatus: open -> closed

nosy: + eric.araujo
messages: + msg304478

resolution: not a bug
stage: resolved
2017-10-10 18:33:30lielfrsetmessages: + msg304066
2017-10-09 20:35:03mdksetnosy: + mdk
messages: + msg303998
2017-10-09 18:06:22lielfrcreate