classification
Title: [EASY] Running test_builtin twice fails on input tty tests
Type: Stage: resolved
Components: Tests Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: readline-related test_builtin failure
View: 13886
Assigned To: Nosy List: serhiy.storchaka, vstinner
Priority: normal Keywords: easy

Created on 2017-10-05 13:41 by vstinner, last changed 2017-10-05 13:51 by vstinner. This issue is now closed.

Messages (3)
msg303765 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-10-05 13:41
haypo@selma$ ./python -m test test_builtin test_builtin -v

======================================================================
FAIL: test_input_tty_non_ascii (test.test_builtin.PtyTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/haypo/prog/python/master/Lib/test/test_builtin.py", line 1717, in test_input_tty_non_ascii
    self.check_input_tty("prompté", b"quux\xe9", "utf-8")
  File "/home/haypo/prog/python/master/Lib/test/test_builtin.py", line 1708, in check_input_tty
    self.assertEqual(input_result, expected)
AssertionError: 'quux' != 'quux\udce9'
- quux
+ quux\udce9
?     +


======================================================================
FAIL: test_input_tty_non_ascii_unicode_errors (test.test_builtin.PtyTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/haypo/prog/python/master/Lib/test/test_builtin.py", line 1721, in test_input_tty_non_ascii_unicode_errors
    self.check_input_tty("prompté", b"quux\xe9", "ascii")
  File "/home/haypo/prog/python/master/Lib/test/test_builtin.py", line 1708, in check_input_tty
    self.assertEqual(input_result, expected)
AssertionError: 'quux' != 'quux\udce9'
- quux
+ quux\udce9
?     +
msg303766 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-10-05 13:50
This is a duplicate of issue13886 (and several other issues).

Why do you think that this issue is easy?
msg303767 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-10-05 13:51
> Why do you think that this issue is easy?

I'm not sure that it's easy :-)
History
Date User Action Args
2017-10-05 13:51:22vstinnersetmessages: + msg303767
2017-10-05 13:50:59serhiy.storchakasetstatus: open -> closed

superseder: readline-related test_builtin failure

nosy: + serhiy.storchaka
messages: + msg303766
resolution: duplicate
stage: resolved
2017-10-05 13:41:53vstinnercreate