classification
Title: Pandas_datareader Error Message - ModuleNotFoundError: No module named 'pandas_datareader' with module in folder
Type: Stage: resolved
Components: Library (Lib), Windows Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Scott Tucholka, eric.araujo, matrixise, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2017-10-02 19:42 by Scott Tucholka, last changed 2017-10-09 09:40 by matrixise. This issue is now closed.

Messages (3)
msg303837 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2017-10-06 16:57
Hello!  Your bug report gives very little information for us to help you.  Can you give details such as: your environement / setup, your code, expected result and full error message?

https://devguide.python.org/tracker/#reporting-an-issue
msg303935 - (view) Author: Scott Tucholka (Scott Tucholka) Date: 2017-10-09 09:35
I am running Windows 10 Enterprise x64 and use Spyder (Python 3.6).

This is my code:
import pandas as pd
import pandas_datareader as dr
dr.get_data_yahoo('AAPL')

I am expecting that the module will import and the get_data_yahoo will
return results for 'AAPL'.

This is my log:
Python 3.6.2 |Anaconda, Inc.| (default, Sep 19 2017, 08:03:39) [MSC v.1900
64 bit (AMD64)]
Type "copyright", "credits" or "license" for more information.
IPython 6.1.0 -- An enhanced Interactive Python.
import pandas as pd
import pandas_datareader as dr
dr.get_data_yahoo('AAPL')
Traceback (most recent call last):
  File "<ipython-input-1-43a2f11394e3>", line 2, in <module>
    import pandas_datareader as dr
ModuleNotFoundError: No module named 'pandas_datareader'

Thanks

On Fri, Oct 6, 2017 at 12:57 PM, Éric Araujo <report@bugs.python.org> wrote:

>
> New submission from Éric Araujo <merwok@netwok.org>:
>
> Hello!  Your bug report gives very little information for us to help you.
> Can you give details such as: your environement / setup, your code,
> expected result and full error message?
>
> https://devguide.python.org/tracker/#reporting-an-issue
>
> ----------
> nosy: +merwok
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <https://bugs.python.org/issue31666>
> _______________________________________
>
msg303938 - (view) Author: Stéphane Wirtel (matrixise) * Date: 2017-10-09 09:40
Hi,

Your bug is related to Pandas and not to Python 3.6.

Maybe you need to post your issue to the bug tracker of Pandas.

You need to install pandas-datareader

pip install pandas-datareader

But it is not an issue with Python.

Have a nice day,
History
Date User Action Args
2017-10-09 09:40:53matrixisesetstatus: open -> closed

nosy: + matrixise
messages: + msg303938

resolution: not a bug
stage: resolved
2017-10-09 09:35:23Scott Tucholkasetmessages: + msg303935
2017-10-06 16:57:36eric.araujosetnosy: + eric.araujo
messages: + msg303837
2017-10-02 19:42:56Scott Tucholkacreate