classification
Title: test_locale failure on OpenBSD
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_getsetlocale_issue1813 failed on OpenBSD
View: 25191
Assigned To: Nosy List: davin, lemburg, loewis, serhiy.storchaka, terry.reedy, xtreak
Priority: normal Keywords: patch

Created on 2017-09-29 09:39 by serhiy.storchaka, last changed 2020-12-08 13:42 by terry.reedy. This issue is now closed.

Messages (3)
msg303320 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-09-29 09:39
$ ./python -m test -vuall -m test_getsetlocale_issue1813 test_locale 
...
test_getsetlocale_issue1813 (test.test_locale.TestMiscellaneous) ... testing with ('tr_TR', 'ISO8859-9') ERROR

======================================================================
ERROR: test_getsetlocale_issue1813 (test.test_locale.TestMiscellaneous)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/serhiy/py/cpython3.7/Lib/test/test_locale.py", line 531, in test_getsetlocale_issue1813
    locale.setlocale(locale.LC_CTYPE, loc)
  File "/home/serhiy/py/cpython3.7/Lib/locale.py", line 604, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting

----------------------------------------------------------------------
msg326336 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2018-09-25 09:46
Related issue on OpenBSD that proposes a patch catching the exception and skipping the test : https://bugs.python.org/issue25191 . I propose closing either of these as duplicate. It seems the PR 9178 was added to the issue by mistake and is not related to this issue.

Thanks
msg382735 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-12-08 13:42
PR-9178 was for #31608.  I corrected the PR and unlinked it from here.

This is a duplicate of #25191, with proposed patch.  #37945 is the same issue for Windows, with extensive discussion.
History
Date User Action Args
2020-12-08 13:42:43terry.reedysetstatus: open -> closed

superseder: test_getsetlocale_issue1813 failed on OpenBSD

nosy: + terry.reedy
messages: + msg382735
resolution: duplicate
stage: patch review -> resolved
2020-12-08 13:38:20terry.reedysetpull_requests: - pull_request8617
2018-09-25 09:46:06xtreaksetnosy: + xtreak
messages: + msg326336
2018-09-11 18:59:25benjamin.petersonsetkeywords: + patch
stage: patch review
pull_requests: + pull_request8617
2017-09-29 09:44:11serhiy.storchakasetnosy: + davin
2017-09-29 09:39:33serhiy.storchakacreate