classification
Title: test_strptime and test_time fail on non-English Windows
Type: behavior Stage: resolved
Components: Library (Lib), Windows Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: time.tzname on Python 3.3.0 for Windows is decoded by wrong encoding
View: 16322
Assigned To: Nosy List: paul.moore, serhiy.storchaka, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2017-09-21 21:53 by serhiy.storchaka, last changed 2017-09-25 08:01 by serhiy.storchaka. This issue is now closed.

Messages (2)
msg302732 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-09-21 21:53
test_strptime and test_time fail on non-English Windows.

For example:

======================================================================
FAIL: test_localtime_timezone (test.test_time.TestPytime)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "C:\Users\Serhiy Storchaka\py\cpython\lib\test\test_time.py", line 643, in test_localtime_timezone
    self.assertEqual(lt.tm_zone, time.tzname[lt.tm_isdst])
AssertionError: 'O?ieyia?y (e?oi)' != '\xd4\xb3\xed\xeb\xff\xed\xe4\xb3\xff (\xeb\xb3\xf2\xee)'
- O?ieyia?y (e?oi)
+ \xd4\xb3\xed\xeb\xff\xed\xe4\xb3\xff (\xeb\xb3\xf2\xee)

Seems there are problems with wrong encodings and lossy encoding on Windows.

>>> '\xd4\xb3\xed\xeb\xff\xed\xe4\xb3\xff (\xeb\xb3\xf2\xee)'
'Ô³íëÿíä³ÿ (ë³òî)'

Looks similar to the string 'O?ieyia?y (e?oi)', isn't?

>>> 'ô³íëÿíä³ÿ (çèìà)'.encode('latin1').decode('cp1251')
'фінляндія (зима)'

Actually it is a string 'фінляндія (зима)' ('Finland (Summer)' in Ukrainian) encoded with cp1251 (Cyrillic ANSI encoding) and misinterpreted as encoded with Latin1.
msg302917 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-09-25 08:01
This looks a duplicate of issue16322.
History
Date User Action Args
2017-09-25 08:01:52serhiy.storchakasetstatus: open -> closed
superseder: time.tzname on Python 3.3.0 for Windows is decoded by wrong encoding
messages: + msg302917

resolution: duplicate
stage: resolved
2017-09-21 21:53:10serhiy.storchakacreate