classification
Title: "Quick search" box renders too wide if font size is large
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.1, Python 3.2, Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Rhamphoryncus, benjamin.peterson, ezio.melotti, georg.brandl, oefe, r.david.murray, rhettinger, tebeka, terry.reedy
Priority: low Keywords: easy

Created on 2008-06-20 21:47 by tebeka, last changed 2012-11-09 13:12 by ezio.melotti. This issue is now closed.

Files
File name Uploaded Description Edit
doc.png tebeka, 2008-06-20 21:47 Screenshot
Messages (15)
msg68479 - (view) Author: Miki Tebeka (tebeka) * Date: 2008-06-20 21:47
See gray area in attached screenshot
msg68481 - (view) Author: Adam Olsen (Rhamphoryncus) Date: 2008-06-20 22:00
Works for me.
msg68482 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-20 22:54
Are you using a pre-final version of Firefox?
msg68483 - (view) Author: Miki Tebeka (tebeka) * Date: 2008-06-20 23:17
Using final version (on Ubuntu 8.04)
msg68486 - (view) Author: Adam Olsen (Rhamphoryncus) Date: 2008-06-20 23:25
That's the same version I'm using.  Maybe there's some font size differences?

I'm also on a 64-bit AMD.
msg68834 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2008-06-27 17:04
It would have been helpful if you had given the url in your message
instead of requiring respondents to read a fuzzy image.

In any case, there is no gray box on Windows XP with FF3 at any zoom
level nor with IE7.  I suggest closing this as idiosyncratic.
msg68842 - (view) Author: Miki Tebeka (tebeka) * Date: 2008-06-27 18:47
I see the big search box on http://docs.python.org/dev/.

The "gray box" is just me highlighting the problematic area in the
picture, not in the actual web site. Sorry I wasn't clear about that.

My settings is FF3 on Untuntu 8.04
msg68844 - (view) Author: Miki Tebeka (tebeka) * Date: 2008-06-27 18:58
Changing the default font in FF to 14 points seems to fix the problem
(my default is 22).
msg68846 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-27 19:15
In that case, I think we can only advise to change the font size and/or
make a Firefox bug report.
msg68857 - (view) Author: Miki Tebeka (tebeka) * Date: 2008-06-27 21:04
When someone reports a problem in a web site, one of the worst answers
is "it's a browser bug - we're not going to fix it".

I agree this should be moved to a lower priority, but closing it is a
bad decision IMO.
msg68859 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2008-06-27 21:50
Running FF3.0 on Windows it looks fine at various font sizes. Maybe this
is unique to the Ubuntu build.

Also, I looked at the style sheet and didn't see anything odd.
msg68865 - (view) Author: Adam Olsen (Rhamphoryncus) Date: 2008-06-28 00:37
I've checked it again, using the font preferences rather than the zoom
setting, and I can reproduce the problem.

Part of the problem stems from using pixels to set the margin, rather
than ems (or whatever the text box is based on).  However, although the
margin (at least visually) scales up evenly, the fonts themselves do
not.  Arguably this is a defect in Firefox, or maybe even the HTML specs
themselves.

Additionally, that only seems to control the visual margin.  I've yet to
figure out what controls the layout (such as wrapping the Go button).
msg68945 - (view) Author: Martina Oefelein (oefe) Date: 2008-06-29 10:32
I can reproduce it with Safari if I enlarge the font size (Cmd +), and it looks like this will happen with 
*any* browser.

Main cause is that the with of the sidebar is set in pixels, while the size of the Quick search box (and the 
sidebar text as well) scales with the font size.

One possible solution would be to set a fixed pixel width for the Quick search box via css. (This wouldn't 
prevent the sidebar text from overflowing, though, but that usually happens only with *very* large font 
sizes, as the browsers first try to wrap the text to fit it into the box. Only if individual words won't fit, 
they overflow.)

Another possible solution would be specify the sidebar with in ems.
msg84469 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-03-30 02:59
I confirm that this happens with FF 3.0.6 on Gentoo Linux if I press the
+ (zoom) key enough times (the page otherwise looks good, but the search
box pokes out of the margin box and overlays text in the content area).
At even larger font sizes it becomes apparent that there is insufficient
gutter between content columns, as well.

Definitely low priority, but it would be nice to fix it.
msg175231 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-11-09 13:12
I can't reproduce this with both the old (2.x) and new (3.x) themes on Firefox 16, so I'm closing this.  If someone can still reproduce it, feel free to reopen it.
History
Date User Action Args
2012-11-09 13:12:19ezio.melottisetstatus: open -> closed
resolution: out of date
messages: + msg175231

stage: needs patch -> resolved
2011-03-30 21:06:02terry.reedysetversions: + Python 3.2, - Python 2.6, Python 3.0
2010-10-29 10:07:21adminsetassignee: georg.brandl -> docs@python
2009-07-01 11:13:20ezio.melottisetnosy: + ezio.melotti
2009-03-30 02:59:18r.david.murraysetstatus: pending -> open

resolution: works for me -> (no value)

keywords: + easy
stage: needs patch
title: "Quick search" box renders too long on FireFox 3 -> "Quick search" box renders too wide if font size is large
nosy: + r.david.murray
versions: + Python 3.0, Python 3.1, Python 2.7
messages: + msg84469
priority: low
type: behavior
2008-06-29 10:32:33oefesetnosy: + oefe
messages: + msg68945
2008-06-28 00:37:23Rhamphoryncussetmessages: + msg68865
2008-06-27 21:50:29rhettingersetnosy: + rhettinger
messages: + msg68859
2008-06-27 21:06:41benjamin.petersonsetstatus: closed -> pending
2008-06-27 21:04:52tebekasetmessages: + msg68857
2008-06-27 19:15:26benjamin.petersonsetstatus: open -> closed
resolution: works for me
messages: + msg68846
2008-06-27 18:58:24tebekasetmessages: + msg68844
2008-06-27 18:47:38tebekasetmessages: + msg68842
2008-06-27 17:04:06terry.reedysetnosy: + terry.reedy
messages: + msg68834
2008-06-20 23:25:57Rhamphoryncussetmessages: + msg68486
2008-06-20 23:17:25tebekasetmessages: + msg68483
2008-06-20 22:54:46benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg68482
2008-06-20 22:00:28Rhamphoryncussetnosy: + Rhamphoryncus
messages: + msg68481
2008-06-20 21:47:32tebekacreate