classification
Title: python 3.6.2 installation failed 0x80070002 error
Type: Stage: resolved
Components: Windows Versions: Python 3.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: malopet, paul.moore, roie, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2017-09-20 15:59 by roie, last changed 2019-08-02 22:47 by steve.dower. This issue is now closed.

Files
File name Uploaded Description Edit
Python 3.6.2 (64-bit)_20170920180757.log roie, 2017-09-20 15:59
Messages (3)
msg302630 - (view) Author: (roie) Date: 2017-09-20 15:59
hello,

i have windows 7 with 64 bit os.
i download the files:
Python 3.6.2 - 2017-07-17:
 Windows x86-64 web-based installer
 Windows x86-64 executable installer.
i clicked run as admin when i tried each one of them.


in the setup window,i clicked on "install now".
it started loading and then showed "setup failed":"0x80070002- the system cannot find the file specified".
i add the log file for more information.
when i searched on the internet, i didn't manage to draw information needed for solution on this matter. 
can you please help me figure it out?
msg302769 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2017-09-22 20:37
If you look in your %TEMP% directory, there should be more log files near the one you attached (most of the filename will be the same).

Could you zip them up and attach all of them here? I think there's some information in one of the others that I'll need to see.

Also, you shouldn't have to run this installer as admin. If you are not planning to install for all users on your machine (and according to the log, you did not select that option), then it may work better if you just run it as yourself.
msg321941 - (view) Author: Marin Petrov (malopet) Date: 2018-07-19 08:59
same error on 
windows 10 64bit 
python 3.6.4

windows user (from windows installation) was named ' pc' - a space as first character. In the log file most paths were c:\users\ pc\... but there was one  c:\users\PC~1\... folowing some error. I didnt make a copy, sorry. I hope this hints for resolving it.

I reinstalled windows with user 'pc' and all was good.
History
Date User Action Args
2019-08-02 22:47:01steve.dowersetstatus: open -> closed
resolution: out of date
stage: resolved
2018-07-19 08:59:51malopetsetnosy: + malopet
messages: + msg321941
2017-09-22 20:37:40steve.dowersetmessages: + msg302769
2017-09-22 18:09:33terry.reedysetnosy: + paul.moore, tim.golden, zach.ware, steve.dower
components: + Windows, - Installation
2017-09-20 15:59:49roiecreate