classification
Title: Stdlib source files not installed
Type: behavior Stage: resolved
Components: Installation, Windows Versions: Python 3.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: paul.moore, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2017-09-14 19:50 by Zero, last changed 2019-10-31 14:22 by Zero. This issue is now closed.

Messages (4)
msg302201 - (view) Author: Stephen Paul Chappell (Zero) Date: 2017-09-14 19:50
Ever since Python 3.6.1, trying to open a Python-source library module in IDLE on Windows (10) has not worked properly since the installer has only been providing *.pyc files. Learning how to use Python has always been easy since it (1) has a great help document, (2) makes it easy to get help() on objects, and (3) allows the source to easily be explored and/or patched. Is there something special that needs to be done to get both the standard library's *.py files and precompile them to *.pyc during installation?

I would be glad to run further tests if the Windows installer can be run headless with specific command-line arguments.
msg302283 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-09-15 18:05
IDLE's class browser is based on stdlib's pyclbr, which processes source.py files.  I have no idea how you install python to not get source files, as source is the default option with the PSF installer.  In any case, this is an install issue, not an IDLE issue.

Since you are asking for the standard behavior, I suspect you must be using an alternate .pyc-only installer. I am therefore inclined to close as 'not a bug'.

If you want further response, please tell us the exact name of the installer and the url where you got it.
msg302291 - (view) Author: Stephen Paul Chappell (Zero) Date: 2017-09-15 19:04
The URL for the installer that was used last is:

https://www.python.org/ftp/python/3.6.2/python-3.6.2-amd64-webinstall.exe
msg348934 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-08-02 23:15
Closing this as out of date, but if you're still watching Zero, make sure you aren't browsing the __pycache__ directory instead of the source directories. We definitely ship sources with all of our distributions.
History
Date User Action Args
2019-10-31 14:22:00Zerosetnosy: - Zero
2019-08-02 23:15:33steve.dowersetstatus: open -> closed
resolution: out of date
messages: + msg348934

stage: resolved
2017-09-15 19:04:34Zerosetmessages: + msg302291
2017-09-15 18:05:23terry.reedysetassignee: terry.reedy ->
messages: + msg302283
components: + Installation, - IDLE, Library (Lib)
title: "Open Module..." Not Working in IDLE for Standard Library -> Stdlib source files not installed
2017-09-14 19:50:17Zerocreate