classification
Title: Configure and make will fail with enabling --with-pydebug
Type: compile error Stage: resolved
Components: Build Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, huzq85
Priority: normal Keywords:

Created on 2017-09-08 17:19 by huzq85, last changed 2017-09-08 17:25 by christian.heimes. This issue is now closed.

Messages (2)
msg301701 - (view) Author: Zhenqing Hu (huzq85) Date: 2017-09-08 17:19
When I updated the source code into the latest version, and configure as well as build with following command:
./configure --with-pydebug && make -j4
Build will fail with following error message:
==================================================================
Could not import runpy module
Traceback (most recent call last):
  File "/home/kevin/research/openSource/cpython/Lib/runpy.py", line 14, in <module>
    import importlib.machinery # importlib first so we can test #15386 via -m
  File "/home/kevin/research/openSource/cpython/Lib/importlib/__init__.py", line 57, in <module>
    import types
  File "/home/kevin/research/openSource/cpython/Lib/types.py", line 175, in <module>
    import functools as _functools
  File "/home/kevin/research/openSource/cpython/Lib/functools.py", line 21, in <module>
    from collections import namedtuple
  File "/home/kevin/research/openSource/cpython/Lib/collections/__init__.py", line 32, in <module>
    from reprlib import recursive_repr as _recursive_repr
  File "/home/kevin/research/openSource/cpython/Lib/reprlib.py", line 7, in <module>
    from _thread import get_ident
ModuleNotFoundError: No module named '_thread'
generate-posix-vars failed
Makefile:561: recipe for target 'pybuilddir.txt' failed
make: *** [pybuilddir.txt] Error 1
==================================================================
msg301702 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2017-09-08 17:25
You have to restart with a clean checkout. Either run ``make distclean`` or ``git clean -xdf`` to get rid of all build files.
History
Date User Action Args
2017-09-08 17:25:15christian.heimessetstatus: open -> closed

nosy: + christian.heimes
messages: + msg301702

resolution: not a bug
stage: resolved
2017-09-08 17:19:03huzq85create