classification
Title: deheader: double #incude of the same file
Type: enhancement Stage: resolved
Components: Build Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Mariatta, dilyan.palauzov, serhiy.storchaka
Priority: normal Keywords:

Created on 2017-08-02 09:51 by dilyan.palauzov, last changed 2018-06-12 21:45 by Mariatta. This issue is now closed.

Messages (3)
msg299650 - (view) Author: Дилян Палаузов (dilyan.palauzov) Date: 2017-08-02 09:51
For cpython 3.6 deheader (http://www.catb.org/esr/deheader/) reports:

Mac/Tools/pythonw.c has more than one inclusion of <Python.h>
Modules/_sre.c has more than one inclusion of "sre_lib.h"
Modules/_testcapimodule.c has more than one inclusion of "testcapi_long.h"
Modules/_threadmodule.c has more than one inclusion of "structmember.h"
Modules/expat/xmltok.c has more than one inclusion of "asciitab.h"
Modules/expat/xmltok.c has more than one inclusion of "latin1tab.h"
Modules/expat/xmltok.c has more than one inclusion of "utf8tab.h"
Modules/faulthandler.c has more than one inclusion of <signal.h>
Objects/unicodeobject.c has more than one inclusion of "stringlib/codecs.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/undef.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/fastsearch.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/split.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/ucs2lib.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/ucs1lib.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/partition.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/find_max_char.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/ucs4lib.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/asciilib.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/find.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/replace.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/localeutil.h"
Objects/unicodeobject.c has more than one inclusion of "stringlib/count.h"
msg299655 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-08-02 11:47
"sre_lib.h" and "stringlib/*.h" are included multiple times for purpose. They are template files and different inclusions instantiate implementations for specific kind of Unicode strings.

"testcapi_long.h" also is a template file.

Modules/expat/xmltok.c is imported file. And it include some header files multiple times for purpose.
msg319404 - (view) Author: Mariatta (Mariatta) * (Python committer) Date: 2018-06-12 21:45
Closing this. No action item from our side.
History
Date User Action Args
2018-06-12 21:45:26Mariattasetstatus: open -> closed

nosy: + Mariatta
messages: + msg319404

resolution: not a bug
stage: resolved
2017-08-02 11:47:50serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg299655
2017-08-02 09:51:51dilyan.palauzovcreate