classification
Title: regrtest.py: "${test_file_name} skipped" message printed twice for each ${test_file_name}
Type: Stage: resolved
Components: Tests Versions: Python 3.7, Python 3.6, Python 3.5, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: vstinner Nosy List: Arfrever, vstinner
Priority: normal Keywords:

Created on 2017-07-31 12:59 by Arfrever, last changed 2019-06-24 13:23 by vstinner. This issue is now closed.

Messages (4)
msg299555 - (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) * (Python triager) Date: 2017-07-31 12:59
Since some change during last 3 months, regrtest.py on 2.7 branch prints "${test_file_name} skipped" message twice for each ${test_file_name}, firstly directly after given ${test_file_name}, and secondly after the following test.

Example:

0:00:06 [ 17/401] test_abc
0:00:06 [ 18/401] test_abstract_numbers
0:00:06 [ 19/401] test_aepack
test_aepack skipped -- No module named aetypes
0:00:06 [ 20/401] test_aifc -- test_aepack skipped
0:00:06 [ 21/401] test_al
test_al skipped -- No module named al
0:00:06 [ 22/401] test_anydbm -- test_al skipped
0:00:08 [ 23/401] test_applesingle
test_applesingle skipped -- No module named MacOS
0:00:08 [ 24/401] test_argparse -- test_applesingle skipped
0:00:14 [ 25/401] test_array
0:00:15 [ 26/401] test_ascii_formatd
0:00:15 [ 27/401] test_ast
msg299587 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-07-31 22:19
The output is correct. First, regrtest says that the test is running. Then
the test is skipped and a message is logged. Finally, the test result is
logged: the test was skipped.

Using -j0, the output is less surprising ;-)
msg299630 - (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) * (Python triager) Date: 2017-08-01 18:59
This bug in output actually occurs in sequential mode.

Apparently problem can be reproduced in 3.*, but only if Tools/scripts/run_tests.py is changed to run tests sequentially. (That problem reported as issue 31098.)

Example from 3.7:

0:00:42 load avg: 1.89 [ 11/405] test_cprofile
0:00:42 load avg: 1.89 [ 12/405] test_winsound
test_winsound skipped -- Use of the 'audio' resource not enabled
0:00:43 load avg: 1.89 [ 13/405] test_pickletools -- test_winsound skipped (resource denied)
0:00:46 load avg: 1.82 [ 14/405] test_select
0:00:58 load avg: 1.54 [ 15/405] test_bisect
msg346398 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-06-24 13:23
To be clear: the output is expected, it was a deliberate choice. I close the issue.
History
Date User Action Args
2019-06-24 13:23:55vstinnersetstatus: open -> closed
resolution: not a bug
messages: + msg346398

stage: resolved
2017-08-01 18:59:50Arfreversetmessages: + msg299630
versions: + Python 3.5, Python 3.6, Python 3.7
2017-07-31 22:19:07vstinnersetmessages: + msg299587
2017-07-31 12:59:50Arfrevercreate