classification
Title: test_socketserver.test_ForkingTCPServer(): threading_cleanup() and reap_children() warnings on AMD64 FreeBSD 10.x Shared 3.x
Type: resource usage Stage: resolved
Components: Tests Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: socketserver.ForkingMixIn.server_close() leaks zombie processes
View: 31151
Assigned To: Nosy List: haypo
Priority: normal Keywords: buildbot

Created on 2017-07-24 09:21 by haypo, last changed 2017-08-10 15:38 by haypo. This issue is now closed.

Messages (2)
msg298942 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-07-24 09:21
http://buildbot.python.org/all/builders/AMD64%20FreeBSD%2010.x%20Shared%203.x/builds/607/steps/test/logs/stdio

test_ForkingTCPServer (test.test_socketserver.SocketServerTest) ... creating server
ADDR = ('127.0.0.1', 42116)
CLASS = <class 'socketserver.ForkingTCPServer'>
server running
test client 0
test client 1
test client 2
waiting for server
done
Warning -- threading_cleanup() failed to cleanup -1 threads after 4 sec (count: 0, dangling: 1)
Warning -- reap_children() reaped child process 83130
ok
...
1 test altered the execution environment:
    test_socketserver
...
Total duration: 11 min 56 sec
Tests result: ENV CHANGED
*** Error code 3
msg300105 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2017-08-10 15:38
I'm not 100% sure, but it looks like a duplicate of bpo-31151.
History
Date User Action Args
2017-08-10 15:38:29hayposetstatus: open -> closed
stage: resolved
2017-08-10 15:38:19hayposetsuperseder: socketserver.ForkingMixIn.server_close() leaks zombie processes
resolution: duplicate
messages: + msg300105
2017-07-24 09:21:13haypocreate