classification
Title: Unable to launch IDLE in windows 7
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Unable to run IDLE without write-access to home directory
View: 8231
Assigned To: terry.reedy Nosy List: terry.reedy, trencyclo
Priority: normal Keywords:

Created on 2017-07-13 13:49 by trencyclo, last changed 2017-09-10 21:38 by terry.reedy. This issue is now closed.

Messages (4)
msg298284 - (view) Author: dongdong (trencyclo) Date: 2017-07-13 13:49
"unable to create user config directory   Z:\.idlerc   check path and permisssion"

It through out this error, when I try to launch the IDLE not as an adminnistrator acount. There is an networed disk memory Z: on my computer

this error is caused by configHandler.py script in the Lib/idlelib directory. Here is a solution: https://www.experts-exchange.com/questions/24006687/Invalid-Python-config-directory.html
msg298373 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-07-14 20:05
This is a duplicate of #8231.  But before I close this, when you do 
> set
in the console (command prompt), what HOME* variables are set and is USERPROFILE?

In python, what does 

>>> from os.path import expanduser
>>> expanduser('~')
show?
msg301832 - (view) Author: dongdong (trencyclo) Date: 2017-09-10 20:57
Hi Terry,
Sorry,  I missed your resply because it was buried in my trash email.
Here are the configuration in my PC:
HOMEDRIVE=Z:
HOMEPATH=\
HOMESHARE=\\nt3.imec.be\zhai65
LOCALAPPDATA=C:\Users\zhai65\AppData\Local

USERPROFILE=C:\Users\zhai65

In python
>>> expanduser('~')
'C:\\Users\\zhai65'

I partly bypassed the bug by following the instructions shown in my
previous link.

*Best Regards!*
*--*

*Eric Donghui **Zhai *
* PhD Candidate*
*IMEC & KU Leuven*

*Mobile: +32-0489 676629 Email: trencyclopedia@gmail.com <zhai.dh@163.com>
 *
*Address: **IMEC, Kapeldreef 75, Leuven, Belgiium*

On 14 July 2017 at 22:05, Terry J. Reedy <report@bugs.python.org> wrote:

>
> Changes by Terry J. Reedy <tjreedy@udel.edu>:
>
>
> ----------
> assignee:  -> terry.reedy
> components: +IDLE
> type: crash -> behavior
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue30918>
> _______________________________________
>
msg301834 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-09-10 21:38
Thanks for the information.  I hope to get to this before 3.6.3.
History
Date User Action Args
2017-09-10 21:38:34terry.reedysetstatus: open -> closed
superseder: Unable to run IDLE without write-access to home directory
messages: + msg301834

resolution: duplicate
stage: resolved
2017-09-10 20:57:04trencyclosetmessages: + msg301832
2017-07-14 20:05:48terry.reedysetassignee: terry.reedy
type: crash -> behavior
components: + IDLE
2017-07-14 20:05:12terry.reedysetnosy: + terry.reedy
messages: + msg298373
2017-07-13 13:49:20trencyclocreate