classification
Title: python 3 git master fails to find libffi and build _ctypes on Mageia v6 x86-64
Type: compile error Stage: resolved
Components: Build Versions: Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: doko, shlomif, zach.ware
Priority: normal Keywords:

Created on 2017-07-12 19:51 by shlomif, last changed 2017-09-06 20:20 by zach.ware. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 2687 merged python-dev, 2017-07-12 20:50
Messages (4)
msg298243 - (view) Author: Shlomi Fish (shlomif) * Date: 2017-07-12 19:51
Running "make" in cpython git master on mageia linux v6 x86-64 gives me this problem with ffi:

<<<<<<<<
running build
running build_ext
Header file /usr/include/ffi.h does not define LIBFFI_H or ffi_wrapper_h
INFO: Could not locate ffi libs and/or headers

The following modules found by detect_modules() in setup.py, have been
built by the Makefile instead, as configured by the Setup files:
atexit                pwd                   time


Failed to build these modules:
_ctypes

running build_scripts
copying and adjusting /home/shlomif/Download/unpack/prog/python/cpython/Tools/scripts/pydoc3 -> build/scripts-3.7
copying and adjusting /home/shlomif/Download/unpack/prog/python/cpython/Tools/scripts/idle3 -> build/scripts-3.7
copying and adjusting /home/shlomif/Download/unpack/prog/python/cpython/Tools/scripts/2to3 -> build/scripts-3.7
copying and adjusting /home/shlomif/Download/unpack/prog/python/cpython/Tools/scripts/pyvenv -> build/scripts-3.7
changing mode of build/scripts-3.7/pydoc3 from 644 to 755
changing mode of build/scripts-3.7/idle3 from 644 to 755
changing mode of build/scripts-3.7/2to3 from 644 to 755
changing mode of build/scripts-3.7/pyvenv from 644 to 755
renaming build/scripts-3.7/pydoc3 to build/scripts-3.7/pydoc3.7
renaming build/scripts-3.7/idle3 to build/scripts-3.7/idle3.7
renaming build/scripts-3.7/2to3 to build/scripts-3.7/2to3-3.7
renaming build/scripts-3.7/pyvenv to build/scripts-3.7/pyvenv-3.7
>>>>>>>

<<<<<<
commit d1cc037d1442cc35d1b194ec8e50901514360949
Author: Victor Stinner <victor.stinner@gmail.com>
Date:   Wed Jul 12 16:05:43 2017 +0200

    bpo-30908: Fix dangling thread in test_os.TestSendfile (#2680)

    tearDown() now clears explicitly the self.server variable to make
    sure that the thread is completely cleared when tearDownClass()
    checks if all threads have been cleaned up.

    Fix the following warning:

    $ ./python -m test --fail-env-changed -m test.test_os.TestSendfile.test_keywords -R 3:1 test_os
    (...)
    Warning -- threading_cleanup() failed to cleanup 0 threads after 3 sec (count: 0, dangling: 2)
    (...)
    Tests result: ENV CHANGED
>>>>>

The problem is that my /usr/include/ffi.h looks like this:

<<<<
#define _MULTIARCH_HEADER ffi.h
#include <multiarch-dispatch.h>
>>>>
msg301492 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2017-09-06 17:48
doko, have you seen/have an opinion on GH-2687?
msg301512 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2017-09-06 20:19
New changeset 6d51b876121e472d4372496d609a26d7e3081c51 by Zachary Ware (Shlomi Fish) in branch 'master':
bpo-30912: Don't check the content of ffi.h (GH-2687)
https://github.com/python/cpython/commit/6d51b876121e472d4372496d609a26d7e3081c51
msg301513 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2017-09-06 20:20
Thanks for the patch!
History
Date User Action Args
2017-09-06 20:20:10zach.waresetstatus: open -> closed
resolution: fixed
messages: + msg301513

stage: resolved
2017-09-06 20:19:21zach.waresetmessages: + msg301512
2017-09-06 17:48:40zach.waresetnosy: + doko
messages: + msg301492
2017-07-12 20:50:29python-devsetpull_requests: + pull_request2752
2017-07-12 19:51:39shlomifcreate