classification
Title: Can't build datetime or time on py3k (r64171)
Type: Stage:
Components: Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: barry Nosy List: barry, georg.brandl, skip.montanaro
Priority: normal Keywords:

Created on 2008-06-12 15:42 by skip.montanaro, last changed 2008-06-12 20:51 by skip.montanaro. This issue is now closed.

Messages (4)
msg68069 - (view) Author: Skip Montanaro (skip.montanaro) * (Python triager) Date: 2008-06-12 15:42
I'm fully up-to-date on my py3k branch (r64171).  After a make clean I
find that I can't build either the time or datetime modules.  Here are
errors from gcc:

building 'time' extension
gcc -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3 -Wall
-Wstrict-prototypes -I. -I/Users/skip/src/python/py3k/./Include
-I/Users/skip/local/include -I. -IInclude -I./Include
-I/opt/local/include -I/Users/skip/src/python/py3k/Include
-I/Users/skip/src/python/py3k -c
/Users/skip/src/python/py3k/Modules/strftime.c -o
build/temp.macosx-10.3-i386-3.0/Users/skip/src/python/py3k/Modules/strftime.o
/Users/skip/src/python/py3k/Modules/strftime.c: In function '_fmt':
/Users/skip/src/python/py3k/Modules/strftime.c:377: error: 'tm'
undeclared (first use in this function)
/Users/skip/src/python/py3k/Modules/strftime.c:377: error: (Each
undeclared identifier is reported only once
/Users/skip/src/python/py3k/Modules/strftime.c:377: error: for each
function it appears in.)
building 'datetime' extension
gcc -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3 -Wall
-Wstrict-prototypes -I. -I/Users/skip/src/python/py3k/./Include
-I/Users/skip/local/include -I. -IInclude -I./Include
-I/opt/local/include -I/Users/skip/src/python/py3k/Include
-I/Users/skip/src/python/py3k -c
/Users/skip/src/python/py3k/Modules/strftime.c -o
build/temp.macosx-10.3-i386-3.0/Users/skip/src/python/py3k/Modules/strftime.o
/Users/skip/src/python/py3k/Modules/strftime.c: In function '_fmt':
/Users/skip/src/python/py3k/Modules/strftime.c:377: error: 'tm'
undeclared (first use in this function)
/Users/skip/src/python/py3k/Modules/strftime.c:377: error: (Each
undeclared identifier is reported only once
/Users/skip/src/python/py3k/Modules/strftime.c:377: error: for each
function it appears in.)

The environment is Mac OS X 10.5.3.

Assigning to Barry since we're so close to beta.

Skip
msg68075 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-06-12 19:43
Where does the strftime.c come from? It is not in the Python sources --
is this a Mac-specific thing?
msg68084 - (view) Author: Skip Montanaro (skip.montanaro) * (Python triager) Date: 2008-06-12 20:46
Georg> Georg Brandl <georg@python.org> added the comment:

    Georg> Where does the strftime.c come from? It is not in the Python
    Georg> sources -- is this a Mac-specific thing?

Whoops.  My bad.  Modified sandbox.  Please reject.

Skip
msg68086 - (view) Author: Skip Montanaro (skip.montanaro) * (Python triager) Date: 2008-06-12 20:51
My bad.  Sorry for the noise.  mods in my sandbox...
History
Date User Action Args
2008-06-12 20:51:10skip.montanarosetstatus: open -> closed
resolution: not a bug
messages: + msg68086
2008-06-12 20:46:04skip.montanarosetmessages: + msg68084
2008-06-12 19:43:04georg.brandlsetnosy: + georg.brandl
messages: + msg68075
2008-06-12 15:42:23skip.montanarocreate