classification
Title: Clean up Demos and Tools
Type: enhancement Stage:
Components: Demos and Tools Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, brett.cannon, dwblas, geon
Priority: high Keywords: easy

Created on 2008-06-12 02:42 by benjamin.peterson, last changed 2009-03-31 23:00 by brett.cannon. This issue is now closed.

Messages (5)
msg68045 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-12 02:42
A good bug day task:

Demos and to some extent Tools has a lot of rubbish in 3.0 that probably
doesn't work with all the module removals and such. Somebody should go
through them and chuck all the old stuff.
msg68742 - (view) Author: David (dwblas) Date: 2008-06-25 19:08
I will take this one on.  I'll download 3.x this weekend and begin.  
What is the best way to proceed?  Post each program as it is changed or a 
note that no change is required?  It can get lengthy if all of the 
programs are posted here.
msg68751 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-25 19:51
On Wed, Jun 25, 2008 at 2:08 PM, David <report@bugs.python.org> wrote:
>
> David <dwblas@gmail.com> added the comment:
>
> I will take this one on.  I'll download 3.x this weekend and begin.
> What is the best way to proceed?  Post each program as it is changed or a
> note that no change is required?  It can get lengthy if all of the
> programs are posted here.

Thanks for volunteering!

Make a list of the ones which should go completely (ie demonstrate
removed modules and features or are broken beyond repair) and post a
patch with changes to the others.
msg79038 - (view) Author: Pavel Kosina (geon) Date: 2009-01-04 05:35
+1

In Tkinter there is still import Tkinter and not import tkinter.
msg84942 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2009-03-31 23:00
This is not really a bug so closing.
History
Date User Action Args
2009-03-31 23:00:30brett.cannonsetstatus: open -> closed

nosy: + brett.cannon
messages: + msg84942

resolution: not a bug
2009-01-04 05:35:19geonsetnosy: + geon
messages: + msg79038
2008-06-25 19:51:40benjamin.petersonsetmessages: + msg68751
2008-06-25 19:08:31dwblassetnosy: + dwblas
messages: + msg68742
2008-06-12 02:42:19benjamin.petersoncreate