classification
Title: Warning -- files was modified by test_import, After: ['@test_4852_tmp.pyc']
Type: Stage: resolved
Components: Tests, Windows Versions: Python 3.5
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: paul.moore, steve.dower, tim.golden, vstinner, zach.ware
Priority: normal Keywords:

Created on 2017-07-03 10:36 by vstinner, last changed 2017-08-11 00:01 by vstinner. This issue is now closed.

Messages (4)
msg297552 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-07-03 10:36
Python 3.5 on Windows emits the following warning when running test_import, but I'm unable to reproduce it :-/

Warning -- files was modified by test_import
  Before: []
  After:  ['@test_4852_tmp.pyc']
msg297553 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-07-03 10:36
Example of warning:
http://buildbot.python.org/all/builders/AMD64%20Windows8.1%20Refleaks%203.5/builds/39/steps/test/logs/stdio
msg297578 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-07-03 13:20
I'm unable to reproduce this bug on my Python 3.5 compiled in debug mode on Windows. I tried "./python -m test -v test_import", "./python -m test -R 3:3 test_import", and with more flags from the buildbot. I also tried to remove __pycache__ directories, it doesn't help.
msg300139 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-08-11 00:01
Python 3.5 doesn't accept bugfixes anymore, so I close this issue.

I never saw this bug on 2.7, 3.6 or master buildbots.
History
Date User Action Args
2017-08-11 00:01:22vstinnersetstatus: open -> closed
resolution: out of date
messages: + msg300139

stage: resolved
2017-07-03 13:20:10vstinnersetmessages: + msg297578
2017-07-03 10:36:17vstinnersetmessages: + msg297553
2017-07-03 10:36:07vstinnercreate