classification
Title: IDLE: add unittests to test_autocomplete
Type: enhancement Stage: resolved
Components: IDLE Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE: Add test_autocomplete unittests
View: 30348
Assigned To: terry.reedy Nosy List: louielu, terry.reedy
Priority: normal Keywords:

Created on 2017-06-12 08:30 by louielu, last changed 2017-10-13 04:42 by berker.peksag. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 2124 closed louielu, 2017-06-12 08:32
Messages (4)
msg295755 - (view) Author: Louie Lu (louielu) * Date: 2017-06-12 08:30
Add unittest to test_open_completions, test_fetch_copmletions, and test_get_entity in test_autocomplete
msg295806 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-06-12 17:46
This issue, and in part the patch, appears to be a duplicate of #30348.  What am I missing?  An issue can have multiple PRs, and one can either replace another one that is closed or augment one that must be applied first.
msg296028 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-06-14 19:40
Ping.  Please answer question about two PRs.

For #30666, I wrote
1. Test_autocomplete.AutoCompleteTest has a test_method for each method of autocomplete.AutoComplete.  The last 5 test methods are empty ('pass'). Finish them.  A couple of the methods might be usefully split into smaller methods.  Get_entity is actually a function, as 'self' is ignored. After the first else, fetch_completions is also independent of 'self'.  PR 2011 combines the two blocks into a function that can be moved to run.py.

These method tests should be supplemented by user action tests with live widgets and simulated key events.  Such tests would be black box tests in that they should be independent of the implementation.

I decided to broaden this issue to all autocomplete tests and narrow that one to autocomplete_w tests.
msg296061 - (view) Author: Louie Lu (louielu) * Date: 2017-06-15 03:07
This is a duplicate of #30348, I forgot there has a exists PR. I'll combine them and finish left 5 unittest in #30348.
History
Date User Action Args
2017-10-13 04:42:07berker.peksagsetsuperseder: IDLE: Add test_autocomplete unittests
2017-06-15 03:07:20louielusetstatus: open -> closed
resolution: duplicate
messages: + msg296061

stage: resolved
2017-06-14 20:21:06terry.reedylinkissue27609 dependencies
2017-06-14 19:40:17terry.reedysetmessages: + msg296028
title: IDLE: add unittest to test_autocomplete -> IDLE: add unittests to test_autocomplete
2017-06-12 17:46:56terry.reedysetmessages: + msg295806
2017-06-12 08:32:30louielusetpull_requests: + pull_request2178
2017-06-12 08:30:22louielucreate