classification
Title: Missing MSI files
Type: Stage: resolved
Components: Windows Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Mark Airey, paul.moore, r.david.murray, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2017-06-11 15:04 by Mark Airey, last changed 2017-06-17 01:31 by terry.reedy. This issue is now closed.

Messages (4)
msg295718 - (view) Author: Mark Airey (Mark Airey) Date: 2017-06-11 15:04
I downloaded and installed python 3.0, 3.6.0 and 3.6.1 and they all said that I was missing: "api-ms-win-crt-runtime-|1-1-0.dll" or the msi files as i have read online. I don't know how to get said files and I need this program soon. Can anyone help?
msg295726 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2017-06-11 18:30
Steve can correct me if I'm wrong, but I think this means your Windows OS isn't up to date.  Googling seems to indicate that this isn't a problem unique to Python.
msg295812 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2017-06-12 19:14
Try installing https://go.microsoft.com/fwlink/?LinkId=746572 separately. This should add the required files, and because it's the "official" installer will provide more details about the underlying error (if any).

You may also need to reboot your machine. This is a system update, not a trivial file installation.
msg296224 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-06-17 01:31
Unless you are experimenting, you only need 3.6.1.  3.0 is deprecated in the sense that it was not meant for production use.

This tracker is for developing the next releases of CPython.  If you have any more questions, try python-list.
History
Date User Action Args
2017-06-17 01:31:10terry.reedysetstatus: open -> closed

nosy: + terry.reedy
messages: + msg296224

resolution: not a bug
stage: resolved
2017-06-12 19:14:52steve.dowersetmessages: + msg295812
2017-06-11 18:30:52r.david.murraysetnosy: + r.david.murray
messages: + msg295726
2017-06-11 15:04:41Mark Aireycreate