classification
Title: Windows HTML Help always opens maximized
Type: enhancement Stage: resolved
Components: Windows Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: chrullrich, docs@python, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2017-06-09 09:20 by chrullrich, last changed 2017-06-09 17:31 by chrullrich. This issue is now closed.

Messages (4)
msg295503 - (view) Author: Christian Ullrich (chrullrich) * Date: 2017-06-09 09:20
The CHM help files on Windows always open maximized. I would prefer they opened in a regular window instead, because the current behavior is annoying.

Fix: In Tools/msi/doc/doc.wxs line 34, change 'Show="maximized"' to 'Show="normal"'.
msg295538 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2017-06-09 15:16
Does 'Show="normal"' cause the usual behavior of "do whatever it was doing when last closed"?  Does 'Show=' need to be specified?

Would you like to submit a PR?
msg295556 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2017-06-09 17:17
Opening in normal size (i.e. randomly positioned somewhere on the screen) is equally annoying.

PR is welcome, but I won't be approving it. Someone else might.

Certainly doesn't need to be backported - this is not a bug.
msg295560 - (view) Author: Christian Ullrich (chrullrich) * Date: 2017-06-09 17:31
I'll have to start with the ceterae again, won't I? OK, since you asked:

Ceterum censeo: This behavior could have been easily adapted to differing local requirements if MSI had been used as the distribution package format by appropriately transforming  the Shortcut table at install time, but burn bundles do not expose an interface to apply transforms to individual component MSIs, needlessly disabling this unique advantage of the Windows Installer technology.

(Apologies to people who know Latin. Unless I'm really lucky here.)

Not sure if the tracker will let me close the bug myself; if it doesn't, know that I have tried.
History
Date User Action Args
2017-06-09 17:31:27chrullrichsetstatus: open -> closed
resolution: not a bug
messages: + msg295560

stage: resolved
2017-06-09 17:17:01steve.dowersetversions: - Python 3.5, Python 3.6
messages: + msg295556

assignee: docs@python ->
components: - Documentation
type: behavior -> enhancement
2017-06-09 15:16:08zach.waresetmessages: + msg295538
versions: + Python 3.5, Python 3.7
2017-06-09 09:20:31chrullrichcreate