classification
Title: [EASY][Windows] test_uname_win32_ARCHITEW6432() of test_platform leaks references
Type: resource usage Stage: resolved
Components: Windows Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Leak in sys.getwindowsversion
View: 30567
Assigned To: Nosy List: eryksun, paul.moore, steve.dower, tim.golden, vstinner, zach.ware
Priority: normal Keywords: easy (C)

Created on 2017-06-02 08:53 by vstinner, last changed 2017-06-07 15:44 by vstinner. This issue is now closed.

Messages (4)
msg294989 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-06-02 08:53
http://buildbot.python.org/all/builders/AMD64%20Windows8.1%20Refleaks%203.6/builds/15/steps/test/logs/stdio

0:00:17 [  4/405/1] test_platform failed
......
beginning 6 repetitions
123456

test_platform leaked [12, 12, 12] references, sum=36
test_platform leaked [4, 4, 4] memory blocks, sum=12


To reproduce the bug, use the command:

python -m test -R 3:3 -m test_uname_win32_ARCHITEW6432 test_platform


Note: Leak isolated my bisect_test.py of bpo-29512.
msg294994 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-06-02 09:06
I tagged this issue as easy. I consider that it's a good exercice for new contributors. Core developers: please let new contributors try to fix it since this issue is not critical, try to explain how to fix it rather than writing the fix ;-)
msg295325 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-06-07 09:26
It seems like the bug was already fixed last days!
msg295350 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-06-07 15:44
Ok, this issue was a duplicate of bpo-30567 which was already fixed.
History
Date User Action Args
2017-06-07 15:44:44vstinnersetstatus: open -> closed
superseder: Leak in sys.getwindowsversion
messages: + msg295350

resolution: duplicate
stage: resolved
2017-06-07 09:26:45vstinnersetmessages: + msg295325
2017-06-02 09:06:57vstinnersetkeywords: + easy (C)

messages: + msg294994
title: [Windows] test_uname_win32_ARCHITEW6432() of test_platform leaks references -> [EASY][Windows] test_uname_win32_ARCHITEW6432() of test_platform leaks references
2017-06-02 08:58:27vstinnersettitle: test_uname_win32_ARCHITEW6432() of test_platform leaks references -> [Windows] test_uname_win32_ARCHITEW6432() of test_platform leaks references
2017-06-02 08:53:09vstinnercreate