classification
Title: test_subprocess creates a core dump on FreeBSD
Type: Stage: resolved
Components: Tests Versions: Python 3.7, Python 3.6, Python 3.5, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: eric.snow, ned.deily, ronaldoussoren, vstinner
Priority: normal Keywords:

Created on 2017-05-24 00:24 by vstinner, last changed 2017-06-30 23:41 by vstinner. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 2515 merged vstinner, 2017-06-30 15:30
Messages (9)
msg294303 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-05-24 00:24
Eric Snow: do you think that it could be related to your recent subinterpreter changes please?

http://buildbot.python.org/all/builders/AMD64%20FreeBSD%20CURRENT%20Debug%203.x/builds/311/steps/test/logs/stdio

0:08:26 load avg: 3.35 [253/405] test_subprocess failed (env changed) (98 sec) -- running: test_io (30 sec)

Warning -- files was modified by test_subprocess
  Before: []
  After:  ['python.core']
msg294318 - (view) Author: Eric Snow (eric.snow) * (Python committer) Date: 2017-05-24 04:25
That looks similar to other failures due to an issue fixed in a later PR.  It shouldn't be an issue any longer.  I'll double check in the morning.
msg294320 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-05-24 04:53
I'm surprised that we only detect hard crashes only indirectly through the
creation of core dump files... Some tests might be enhanced to raise an
exception at least if the process was killed by a signal, maybe also if the
exit code is non-zero (depending on the test).

We had a similar but different issue in test_io which created a core dump
on a deliberate crash.
msg294512 - (view) Author: Eric Snow (eric.snow) * (Python committer) Date: 2017-05-25 20:12
At this point I'm not convinced the failure is due to my recent changes.  Regardless, I do agree with you about detecting hard crashes.
msg294824 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-05-31 08:27
Sadly, I'm unable to reproduce the issue on my FreeBSD 11 VM :-(
msg296971 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-06-26 23:13
Oops, I mentioned the wrong bpo in my PRs: the fix was pushed using bpo-30764 identifier :-/
msg297055 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-06-27 16:20
It seems like test_child_terminated_in_stopped_state() of test_subprocess on Python 2.7 fails on some macOS versions, see:
http://bugs.python.org/issue30764#msg296966

Can someone please try to reproduce the bug? I'm unable to reproduce the bug on Darwin 16.5.0 (macOS Sierra?).
msg297453 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-06-30 23:01
New changeset fd93f37f0dc537eb7edca7b75e2f92ef54dd2833 by Victor Stinner in branch '2.7':
bpo-30448: Fix support.SuppressCrashReport on macOS (#2515)
https://github.com/python/cpython/commit/fd93f37f0dc537eb7edca7b75e2f92ef54dd2833
msg297454 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-06-30 23:41
macOS 2.7 buildbots are back. All known bugs are fixed, I close the issue.
History
Date User Action Args
2017-06-30 23:41:31vstinnersetstatus: open -> closed
versions: + Python 2.7, Python 3.5, Python 3.6
messages: + msg297454

resolution: fixed
stage: resolved
2017-06-30 23:01:30vstinnersetmessages: + msg297453
2017-06-30 15:30:14vstinnersetpull_requests: + pull_request2585
2017-06-27 16:20:43vstinnersetnosy: + ronaldoussoren, ned.deily
messages: + msg297055
2017-06-26 23:13:51vstinnersetmessages: + msg296971
2017-05-31 08:27:55vstinnersetmessages: + msg294824
2017-05-25 20:12:54eric.snowsetmessages: + msg294512
2017-05-24 04:53:30vstinnersetmessages: + msg294320
2017-05-24 04:25:07eric.snowsetmessages: + msg294318
2017-05-24 00:24:03vstinnercreate