classification
Title: Sphinx 1.6.1 raising new warnings in docs build
Type: Stage: resolved
Components: Documentation Versions: Python 3.7, Python 3.6, Python 3.5, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: brett.cannon, docs@python, serhiy.storchaka
Priority: critical Keywords:

Created on 2017-05-16 17:29 by brett.cannon, last changed 2017-05-23 01:10 by brett.cannon. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 1612 merged Mariatta, 2017-05-16 17:54
PR 1613 merged serhiy.storchaka, 2017-05-16 18:18
PR 1614 merged serhiy.storchaka, 2017-05-16 20:24
PR 1615 merged serhiy.storchaka, 2017-05-16 20:28
PR 1616 merged serhiy.storchaka, 2017-05-16 20:34
PR 1617 merged brett.cannon, 2017-05-16 21:01
PR 1618 merged brett.cannon, 2017-05-16 21:05
PR 1619 merged brett.cannon, 2017-05-16 21:15
PR 1744 merged brett.cannon, 2017-05-23 00:18
Messages (14)
msg293775 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2017-05-16 17:29
The Travis file uses `make venv` which does `python3 -m pip install --upgrade sphinx` which is pulling in Sphinx 1.6.1 which was released today (under Python 2.7 the pip call is direct instead of using `make venv`). The problem is that Sphinx 1.6.1 adds some new warnings that then is flagging the docs build as failing.

To fix this we should probably stop calling `make venv` in .travis.yml and instead explicitly install Sphinx 1.5.6 for the docs build.

Once Travis is green again a separate PR can be done to update `master` to build cleanly under Sphinx 1.6.1.
msg293776 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2017-05-16 17:30
Technically it's probably best to do `python3 -m pip install sphinx~=1.5.6` so bugfix releases are picked up.
msg293777 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-05-16 18:20
PR 1613 tries to fix a warning by using explicit footnote numbering.
msg293779 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-05-16 20:18
New changeset d97b7dc94b19063f0589d401bdc4aaadc7030762 by Serhiy Storchaka in branch 'master':
bpo-30380: Fix Sphinx 1.6.1 warnings. (#1613)
https://github.com/python/cpython/commit/d97b7dc94b19063f0589d401bdc4aaadc7030762
msg293783 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2017-05-16 20:48
New changeset fca224f117d25bdfec1bf7160b67438c4fcf6dee by Brett Cannon (Mariatta) in branch 'master':
bpo-30380: Pin the version of Sphinx used to build the documentation (GH-1612)
https://github.com/python/cpython/commit/fca224f117d25bdfec1bf7160b67438c4fcf6dee
msg293788 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-05-16 21:09
New changeset 8fc1ff51adb52c80f6bf78393413c72543bae3e1 by Serhiy Storchaka in branch '3.6':
[3.6] bpo-30380: Fix Sphinx 1.6.1 warnings. (GH-1613) (#1614)
https://github.com/python/cpython/commit/8fc1ff51adb52c80f6bf78393413c72543bae3e1
msg293795 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2017-05-16 21:28
New changeset 5e2016dce92d66e6e1fb25e6ce39031d8c7d5412 by Brett Cannon in branch '3.6':
bpo-30380: Pin the version of Sphinx used to build the docs (GH-1612) (GH-1617)
https://github.com/python/cpython/commit/5e2016dce92d66e6e1fb25e6ce39031d8c7d5412
msg293797 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2017-05-16 21:29
New changeset 083f13e34c0b9f9ed4ed64fed3989d4af97843b3 by Brett Cannon (Serhiy Storchaka) in branch '3.5':
[3.5] bpo-30380: Fix Sphinx 1.6.1 warnings. (GH-1613) (GH-1615)
https://github.com/python/cpython/commit/083f13e34c0b9f9ed4ed64fed3989d4af97843b3
msg293800 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2017-05-16 21:40
New changeset 77606957e71ce477d2c5569718f0fc36f05c6f59 by Brett Cannon in branch '3.5':
bpo-30380: Pin the version of Sphinx used to build the documentation (GH-1612) (GH-1618)
https://github.com/python/cpython/commit/77606957e71ce477d2c5569718f0fc36f05c6f59
msg293801 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2017-05-16 21:41
New changeset 97eb2a7d77011605e8fc49e754cd371ead4366bc by Brett Cannon in branch '2.7':
[2.7] bpo-30380: Pin the version of Sphinx used to build the docs (GH-1612) (GH-1619)
https://github.com/python/cpython/commit/97eb2a7d77011605e8fc49e754cd371ead4366bc
msg293802 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2017-05-16 21:46
All branches should be green again. Serhiy has a PR out to fix 2.7 for Sphinx 1.6.1, but it isn't passing yet so that branch is pinned to 1.5.6 until then.

I will leave this issue open for Serhiy to close once his 2.7 PR is merged.
msg293812 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-05-16 22:26
New changeset b8b9f95f660d00ce9bd11bd9de429176858be3c5 by Serhiy Storchaka in branch '2.7':
[2.7] bpo-30380: Fix Sphinx 1.6.1 warnings. (GH-1613) (#1616)
https://github.com/python/cpython/commit/b8b9f95f660d00ce9bd11bd9de429176858be3c5
msg293843 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-05-17 06:16
There was other warnings, mostly false positive, but there were also the real documentation bugs. Sphinx now converts quotes to Unicode variants at earlier stage (this is good thing, because converting them at late stage, in HTML, not always worked), and rules in susp-ignored.csv containing '"' no longer worked.

Now warnings in 2.7 are fixed and Sphinx can be pinned to 1.6.1.
msg294210 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2017-05-23 01:10
All branches are now pinned to and working under Sphinx 1.6.1, so I'm closing this as fixed!
History
Date User Action Args
2017-05-23 01:10:26brett.cannonsetstatus: open -> closed
resolution: fixed
messages: + msg294210

stage: resolved
2017-05-23 00:18:34brett.cannonsetpull_requests: + pull_request1833
2017-05-17 06:16:17serhiy.storchakasetmessages: + msg293843
2017-05-16 22:26:50serhiy.storchakasetmessages: + msg293812
2017-05-16 21:46:52brett.cannonsetmessages: + msg293802
2017-05-16 21:41:02brett.cannonsetmessages: + msg293801
2017-05-16 21:40:35brett.cannonsetmessages: + msg293800
2017-05-16 21:29:44brett.cannonsetmessages: + msg293797
2017-05-16 21:28:23brett.cannonsetmessages: + msg293795
2017-05-16 21:15:52brett.cannonsetpull_requests: + pull_request1708
2017-05-16 21:09:25serhiy.storchakasetmessages: + msg293788
2017-05-16 21:05:42brett.cannonsetpull_requests: + pull_request1707
2017-05-16 21:01:49brett.cannonsetpull_requests: + pull_request1706
2017-05-16 20:48:28brett.cannonsetmessages: + msg293783
2017-05-16 20:34:33serhiy.storchakasetpull_requests: + pull_request1705
2017-05-16 20:28:37serhiy.storchakasetpull_requests: + pull_request1704
2017-05-16 20:24:31serhiy.storchakasetpull_requests: + pull_request1703
2017-05-16 20:18:12serhiy.storchakasetmessages: + msg293779
2017-05-16 18:20:15serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg293777
2017-05-16 18:18:08serhiy.storchakasetpull_requests: + pull_request1702
2017-05-16 17:54:29Mariattasetpull_requests: + pull_request1701
2017-05-16 17:30:24brett.cannonsetmessages: + msg293776
2017-05-16 17:29:33brett.cannoncreate