classification
Title: x86 Windows7 3.x buildbot has the issue #26624 bug
Type: Stage: resolved
Components: Tests, Windows Versions: Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: db3l, paul.moore, steve.dower, tim.golden, vstinner, zach.ware
Priority: normal Keywords: buildbot

Created on 2017-04-26 14:50 by vstinner, last changed 2017-05-02 13:56 by vstinner. This issue is now closed.

Messages (6)
msg292356 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-04-26 14:50
It looks like the x86 Windows7 3.x buildbot has the issue #26624 bug: test__locale hangs.

This buildbot slave is managed by David Bolen.

@David: please see:
* https://developer.microsoft.com/en-US/windows/downloads/windows-10-sdk
* https://bugs.python.org/issue26624#msg270695


http://buildbot.python.org/all/builders/x86%20Windows7%203.x/builds/549/steps/compile/logs/stdio

ValidateUcrtbase:
  setlocal
  set PYTHONPATH=D:\cygwin\home\db3l\buildarea\3.x.bolen-windows7\build\Lib
  "D:\cygwin\home\db3l\buildarea\3.x.bolen-windows7\build\PCBuild\win32\python_d.exe" "D:\cygwin\home\db3l\buildarea\3.x.bolen-windows7\build\PC\validate_ucrtbase.py" ucrtbased
  C:\Windows\system32\ucrtbased.dll is version 10.0.10240.16384
  WARN: ucrtbased contains known issues. Please update the Windows 10 SDK.
  See:
    http://bugs.python.org/issue27705
    https://developer.microsoft.com/en-US/windows/downloads/windows-10-sdk


http://buildbot.python.org/all/builders/x86%20Windows7%203.x/builds/549/steps/test/logs/stdio

0:58:28 [335/404] test_base64 passed
running: test_venv (56 sec), test__locale (30 sec)
...

1:07:49 [403/404] test_asyncgen passed -- running: test__locale (562 sec)

command timed out: 3600 seconds without output running ['Tools\\buildbot\\test.bat', '-j2'], attempting to kill
running: test__locale (592 sec)
...

running: test__locale (4162 sec)
2:07:54 [404/404/1] test__locale crashed (Exit code 1)
program finished with exit code 1
elapsedTime=7680.676000
msg292490 - (view) Author: David Bolen (db3l) Date: 2017-04-28 00:22
Ok, I believe I've got the latest ucrtbased now on the Win7 buildbot (validate_ucrtbase.py reports it as 10.0.15063.137).

It appears as if my Win8 and Win10 buildbots also have the older dll, so I'm guessing they're just fast enough or lucky enough not to run into the issue.  I'll plan on addressing them in the near future as well.
msg292497 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-04-28 01:33
@David: Oh, a build on x86 Windows7 3.5 just failed on the git step with a strange erorr:

http://buildbot.python.org/all/builders/x86%20Windows7%203.5/builds/209/steps/git/logs/err.text

twisted.spread.pb.RemoteError: unrecognized SlaveCommand 'stat'
msg292498 - (view) Author: David Bolen (db3l) Date: 2017-04-28 01:42
Yeah, there were a few transient build errors while I was getting the buildbot back online.  My initial attempt to fix this ticket involved using the VS 2015 installer which turned out very badly, so I had to fall back to an older VM image and start over.  But the older image had an older buildbot version which didn't work with the git workflow, which hit a few pending builds before I got it fixed.

I'm not yet sure if there may be some other fallback (e.g., the link error in the recent 3.x build seems familiar but I can't recall why offhand)
msg292499 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-04-28 01:44
> Yeah, there were a few transient build errors while I was getting the buildbot back online

Oh ok, I understand that the issue is already fixed. Thanks :-)
msg292758 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-05-02 13:56
I don't see the bug again, I confirm that the bug was fixed. Thanks David.
History
Date User Action Args
2017-05-02 13:56:35vstinnersetstatus: open -> closed
resolution: fixed
messages: + msg292758

stage: resolved
2017-04-28 01:44:02vstinnersetmessages: + msg292499
2017-04-28 01:42:51db3lsetmessages: + msg292498
2017-04-28 01:33:07vstinnersetmessages: + msg292497
2017-04-28 00:22:45db3lsetmessages: + msg292490
2017-04-26 14:50:09vstinnercreate