classification
Title: test_venv failed without pip
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: serhiy.storchaka, vinay.sajip
Priority: normal Keywords:

Created on 2017-04-21 06:01 by serhiy.storchaka, last changed 2017-04-21 06:51 by serhiy.storchaka. This issue is now closed.

Messages (4)
msg292009 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-04-21 06:01
$ ./python -m test.regrtest -vuall test_venv
...
======================================================================
FAIL: test_with_pip (test.test_venv.EnsurePipTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/serhiy/py/cpython3.5/Lib/test/test_venv.py", line 428, in test_with_pip
    self.do_test_with_pip(False)
  File "/home/serhiy/py/cpython3.5/Lib/test/test_venv.py", line 382, in do_test_with_pip
    self.assertEqual(err, "")
AssertionError: '/tmp/tmpxhgghyhm/bin/python: No module named pip\n' != ''
- /tmp/tmpxhgghyhm/bin/python: No module named pip


----------------------------------------------------------------------
msg292010 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2017-04-21 06:24
I can't reproduce this on the master branch, with the latest checkout. Was this the branch your failure occurred on?

$ ./python -m test.regrtest -vuall test_venv
== CPython 3.7.0a0 (heads/master:f60c9e5, Apr 21 2017, 07:19:01) [GCC 5.4.0 20160609]
==   Linux-4.4.0-72-generic-x86_64-with-debian-stretch-sid little-endian
==   hash algorithm: siphash24 64bit
==  cwd: /home/vinay/projects/python/master/build/test_python_4297
==  encodings: locale=UTF-8, FS=utf-8
Testing with flags: sys.flags(debug=0, inspect=0, interactive=0, optimize=0, dont_write_bytecode=0, no_user_site=0, no_site=0, ignore_environment=0, verbose=0, bytes_warning=0, quiet=0, hash_randomization=1, isolated=0)
Run tests sequentially
0:00:00 [1/1] test_venv
test_defaults (test.test_venv.BasicTest) ... ok
test_executable (test.test_venv.BasicTest) ... ok
test_executable_symlinks (test.test_venv.BasicTest) ... ok
test_isolation (test.test_venv.BasicTest) ... ok
test_overwrite_existing (test.test_venv.BasicTest) ... ok
test_prefixes (test.test_venv.BasicTest) ... ok
test_prompt (test.test_venv.BasicTest) ... ok
test_symlinking (test.test_venv.BasicTest) ... ok
test_unoverwritable_fails (test.test_venv.BasicTest) ... ok
test_upgrade (test.test_venv.BasicTest) ... ok
test_devnull (test.test_venv.EnsurePipTest) ... ok
test_explicit_no_pip (test.test_venv.EnsurePipTest) ... ok
test_no_pip_by_default (test.test_venv.EnsurePipTest) ... ok
test_with_pip (test.test_venv.EnsurePipTest) ... ok

----------------------------------------------------------------------
Ran 14 tests in 9.336s

OK
1 test OK.
msg292011 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-04-21 06:37
Actually I tested on 3.5 and 3.6. I can't reproduce on master.
msg292012 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-04-21 06:51
Hmm, seems this is local issue of my environment. I now use very small disk, and after building several Python branches and running tests only 16 MB of free space were left.
History
Date User Action Args
2017-04-21 06:51:08serhiy.storchakasetstatus: open -> closed
resolution: works for me
messages: + msg292012

stage: resolved
2017-04-21 06:37:49serhiy.storchakasetmessages: + msg292011
versions: - Python 3.7
2017-04-21 06:24:03vinay.sajipsetmessages: + msg292010
2017-04-21 06:01:20serhiy.storchakacreate