classification
Title: Failed to build these modules: _ctypes
Type: Stage: resolved
Components: Build Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: eamanu, louielu, shihai1991
Priority: normal Keywords:

Created on 2017-04-17 16:27 by eamanu, last changed 2019-07-05 18:14 by shihai1991. This issue is now closed.

Messages (4)
msg291800 - (view) Author: Emmanuel Arias (eamanu) * Date: 2017-04-17 16:27
Hello everybody, 

I am working with the code.

I clone the repo, and make a pull upstream of github's cpython repository (master branch), and when I make:

    ./configure --with-pydebug && make -j

build correctly but finished with this message:

    Failed to build these modules:
    _ctypes   

But the Test Result is: SUCCESS

Regards
msg291803 - (view) Author: Louie Lu (louielu) * Date: 2017-04-17 16:42
Are you using Ubuntu or other Linux distribution? This problem is because you didn't install the dependency package.

You may first try to use the instruction at devguide:
http://cpython-devguide.readthedocs.io/setup.html#build-dependencies

Or, assume you have install build-essential and python3-dev ...etc., maybe you lost to install libffi-dev, just simply `apt-get install libffi-dev` and rebuild to solve this problem.
msg291807 - (view) Author: Emmanuel Arias (eamanu) * Date: 2017-04-17 17:46
The problem was solution making:

    apt-get install libffi-dev

Thanks
msg347365 - (view) Author: hai shi (shihai1991) * Date: 2019-07-05 18:14
In centos, `sudo yum install -y libffi libffi-devel` should worked
History
Date User Action Args
2019-07-05 18:14:07shihai1991setnosy: + shihai1991
messages: + msg347365
2017-04-17 17:55:43eric.smithsetstatus: open -> closed
resolution: not a bug
stage: resolved
2017-04-17 17:46:23eamanusetmessages: + msg291807
2017-04-17 16:45:51louielusettype: compile error ->
components: + Build, - Interpreter Core
2017-04-17 16:42:50louielusetnosy: + louielu
messages: + msg291803
2017-04-17 16:27:57eamanucreate