classification
Title: pdb issue with type conversion
Type: Stage: resolved
Components: Extension Modules Versions: Python 3.6, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Christoph Zimmermann, Cuong Manh Le
Priority: normal Keywords:

Created on 2017-04-17 06:15 by Christoph Zimmermann, last changed 2017-04-17 10:27 by r.david.murray. This issue is now closed.

Messages (3)
msg291786 - (view) Author: Christoph Zimmermann (Christoph Zimmermann) Date: 2017-04-17 06:15
Types cannot be converted properly while running under pdb control:

python
>>> t=(1,2,3)
>>> list(t)
[1, 2, 3]

python pdb.py
(Pdb) t=(1,2,3)
(Pdb) list(t)
*** Error in argument: '(t)'
msg291787 - (view) Author: Cuong Manh Le (Cuong Manh Le) Date: 2017-04-17 06:37
list is a pdb command, not the builtin list when you called it in pdb
msg291790 - (view) Author: Christoph Zimmermann (Christoph Zimmermann) Date: 2017-04-17 08:28
Thanks for the hint!
History
Date User Action Args
2017-04-17 10:27:00r.david.murraysetresolution: not a bug
2017-04-17 08:28:44Christoph Zimmermannsetstatus: open -> closed

messages: + msg291790
stage: resolved
2017-04-17 06:37:29Cuong Manh Lesetnosy: + Cuong Manh Le
messages: + msg291787
2017-04-17 06:15:46Christoph Zimmermanncreate