classification
Title: anaconda3::traitsu::NotImplementedError
Type: behavior Stage: resolved
Components: Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: berker.peksag, leopoldotosi
Priority: normal Keywords:

Created on 2017-04-13 13:09 by leopoldotosi, last changed 2017-04-13 13:38 by berker.peksag. This issue is now closed.

Messages (2)
msg291611 - (view) Author: leopoldo (leopoldotosi) Date: 2017-04-13 13:09
the code below crash when run on anaconda3



import traits.api as trapi
import traitsui.api as trui

from traits.api import HasTraits, Str, Range, Enum

class Person(HasTraits):
    name = Str('Jane Doe')
    age = Range(low=0)
    gender = Enum('female', 'male')

person = Person(age=30)

from traitsui.api import Item, RangeEditor, View

person_view = View(
    Item('name'),
    Item('gender'),
    Item('age', editor=RangeEditor(mode='spinner')),
    buttons=['OK', 'Cancel'],
    resizable=True,
)


person.configure_traits(view=person_view)
---------------------------------------------------------------------------
NotImplementedError                       Traceback (most recent call last)
<ipython-input-18-3929f77bb9e4> in <module>()
----> 1 person.configure_traits(view=person_view)

/home/leopoldo/anaconda3/lib/python3.6/site-packages/traits/has_traits.py in configure_traits(self, filename, view, kind, edit, context, handler, id, scrollable, **args)
   2169                 context = self
   2170             rc = toolkit().view_application( context, self.trait_view( view ),
-> 2171                                            kind, handler, id, scrollable, args )
   2172             if rc and (filename is not None):
   2173                 fd = None

/home/leopoldo/anaconda3/lib/python3.6/site-packages/traitsui/toolkit.py in view_application(self, context, view, kind, handler, id, scrollable, args)
    289 
    290         """
--> 291         raise NotImplementedError
    292 
    293     #---------------------------------------------------------------------------

NotImplementedError:
msg291615 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2017-04-13 13:38
Please report this to either traits or traitsui developers. This issue tracker is for issues with CPython and its standard library, not for third-party modules on PyPI.
History
Date User Action Args
2017-04-13 13:38:25berker.peksagsetstatus: open -> closed

type: crash -> behavior

nosy: + berker.peksag
messages: + msg291615
resolution: not a bug
stage: resolved
2017-04-13 13:09:16leopoldotosicreate