classification
Title: error of parsing encoded words in email of standard library
Type: behavior Stage: resolved
Components: email Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: barry, r.david.murray, rhettinger, sijian liang
Priority: normal Keywords:

Created on 2017-04-05 09:30 by sijian liang, last changed 2017-04-05 17:39 by r.david.murray. This issue is now closed.

Messages (5)
msg291171 - (view) Author: sijian liang (sijian liang) Date: 2017-04-05 09:30
This issue is fixed in python3
see https://github.com/python/cpython/commit/07ea53cb218812404cdbde820647ce6e4b2d0f8e
msg291182 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2017-04-05 15:26
Barry, is this something that should go back to 2.7 or is that pretty much settled business at this point?
msg291184 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2017-04-05 15:32
On Apr 05, 2017, at 03:26 PM, Raymond Hettinger wrote:

>Barry, is this something that should go back to 2.7 or is that pretty much
>settled business at this point?

I think we should not backport this.  It's a behavior change and my concern
would be that anybody who's bitten by this in Python 2.7 is either already
dealing with it or has already worked around it.  I wouldn't want to change
that in a 2.7 point release.

@r.david.murray might have a different opinion.
msg291189 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2017-04-05 17:34
I consciously decided not to backport this to 2.7 at the time, though I'm not sure I said that out loud.  I think it is too much of a behavior change for 2.7.
msg291190 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2017-04-05 17:39
Actually, looking at the issue related to the patch, we conferred at the time, Barry, and decided on no backports.  It was applied only to default.  Sijian: the reason we put the issue number in the commit message is because the issue often contains relevant discussion that can supplement the commit message.
History
Date User Action Args
2017-04-05 17:39:17r.david.murraysetresolution: rejected -> not a bug
messages: + msg291190
2017-04-05 17:34:29r.david.murraysetstatus: open -> closed
resolution: rejected
messages: + msg291189

stage: resolved
2017-04-05 15:32:42barrysetmessages: + msg291184
2017-04-05 15:26:37rhettingersetnosy: + rhettinger
messages: + msg291182
2017-04-05 09:30:45sijian liangcreate