classification
Title: Issue in extending documentation
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Namjun Kim, docs@python, martin.panter, terry.reedy
Priority: normal Keywords:

Created on 2017-04-04 02:36 by Namjun Kim, last changed 2017-04-07 19:29 by terry.reedy. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 983 closed python-dev, 2017-04-04 04:15
Messages (3)
msg291098 - (view) Author: Namjun Kim (Namjun Kim) * Date: 2017-04-04 02:36
https://docs.python.org/3.7/extending/extending.html

"Should it become a dangling pointer, C code which raises the exception could cause a core dump or other unintended side effects."

The typo error in this sentence.

"If it become a dangling pointer, C code which raises the exception could cause a core dump or other unintended side effects."

fix the typo error.
msg291099 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2017-04-04 03:12
FWIW I don’t see any error in the first quote. “Should X happen, Y happens” is valid English. Though I admit this kind of grammar is not used that often.

If it is too hard to understand, it should be okay to change it to “If it becomes a danging pointer, . . .”.

[become → becomes]
msg291287 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-04-07 19:29
I agree with the rejection on the PR.
History
Date User Action Args
2017-04-07 19:29:47terry.reedysetstatus: open -> closed

type: behavior

nosy: + terry.reedy
messages: + msg291287
resolution: not a bug
stage: resolved
2017-04-04 04:15:21python-devsetpull_requests: + pull_request1156
2017-04-04 03:12:35martin.pantersetnosy: + martin.panter
messages: + msg291099
2017-04-04 02:36:41Namjun Kimcreate