classification
Title: setuptools: bdist_wininst adds duplicate entry to dist_files
Type: behavior Stage:
Components: Distutils Versions: 3rd party
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: htgoebel, loewis
Priority: normal Keywords:

Created on 2008-05-22 15:00 by htgoebel, last changed 2008-05-23 18:54 by loewis. This issue is now closed.

Files
File name Uploaded Description Edit
simple-0.0.0.0.1.tar.gz htgoebel, 2008-05-22 15:00 simple package to show the bug
Messages (3)
msg67193 - (view) Author: Hartmut Goebel (htgoebel) Date: 2008-05-22 15:00
In setuptools 0.6c8 has a bug in bdist_wininst:

Distribution files are listed twice
``distribution.dist_files``. This hinders developing tools which use
this data. In addition ``upload`` will upload the file twice to pypi.

I need this bug fixed for automated upload of files using
<http://origo-submit.origo.ethz.ch>;.

Enclosed please find a simple package to show the bug. Just run

   python setup.py bdist_wininst

this shows one entry. Now run

   python setup-setuptools.py bdist_wininst

this shows two entires.

The only difference between both setup files is wherefrom setup() is
imported.
msg67205 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-05-22 19:56
Is that a bug in setuptools? If so, don't report it here - setuptools is
a separate project, not part of the core Python (bdist_wininst is part
of distutils).
msg67258 - (view) Author: Hartmut Goebel (htgoebel) Date: 2008-05-23 17:51
Yes. I've coincidently found the setptools bugtracker today and filed a
bug-report there.

Please Close.
History
Date User Action Args
2008-05-23 18:54:09loewissetstatus: open -> closed
resolution: not a bug
versions: + 3rd party, - Python 2.5
2008-05-23 17:51:32htgoebelsetmessages: + msg67258
2008-05-22 19:56:04loewissetnosy: + loewis
messages: + msg67205
2008-05-22 15:00:56htgoebelcreate