classification
Title: Re-running Windows installer should have option to set PATH
Type: enhancement Stage: resolved
Components: Installation, Windows Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: brondsem, eryksun, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2017-02-04 15:29 by brondsem, last changed 2017-02-04 21:04 by steve.dower. This issue is now closed.

Messages (5)
msg286968 - (view) Author: Dave Brondsema (brondsem) * Date: 2017-02-04 15:29
If you miss the checkbox to set the "PATH" when installing Python for the first time, there isn't any easy way to set it again.  (And for new programmers, having it set automatically is extremely useful).  Uninstalling and re-installing does work to get PATH set, but that isn't ideal.

When you re-run the installer it does offer "Modify" and "Repair" options, but neither of those let you set the PATH.  It would be nice if "Modify" did offer that option.
msg286969 - (view) Author: Dave Brondsema (brondsem) * Date: 2017-02-04 15:36
A colleague has pointed out to me that this is available in the 2nd step within "Modify".  I didn't realize there were more options after the first "Modify" screen.  So perhaps the UI could be improved, but the functionality is there.
msg286970 - (view) Author: Eryk Sun (eryksun) * (Python triager) Date: 2017-02-04 15:49
The user is presented with 3 buttons: Back, Next, and Cancel. The "Next" button is the only way forward to modify the installation. Did you assume "Next" would start the modification rather than take you to another dialog with options? How about if it had a more detailed name like "Next (Advanced Options)"?
msg286972 - (view) Author: Dave Brondsema (brondsem) * Date: 2017-02-04 15:55
Yes, exactly.
msg286995 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2017-02-04 21:03
I consider this another vote against putting the check box on the front page of the installer, rather than a positive vote for any particular change.

There's no way to miss the screen with the real checkbox when you are modifying the install, and modifying PATH from any installer is not recommended in any case.

The py.exe launcher is recommended on Windows, or modifying your PATH for a console session rather than globally (granted, we don't offer much to help in the latter case other than the activate script for virtual environments, but I'm open to ideas).

Adding check boxes in random places in the installer or changing buttons from their conventional text is not going to happen (on my watch).
History
Date User Action Args
2017-02-04 21:04:09steve.dowersetstatus: open -> closed
resolution: not a bug
stage: resolved
2017-02-04 21:03:51steve.dowersetmessages: + msg286995
2017-02-04 15:55:37brondsemsetmessages: + msg286972
2017-02-04 15:49:16eryksunsetnosy: + eryksun
messages: + msg286970
2017-02-04 15:36:57brondsemsetmessages: + msg286969
2017-02-04 15:29:17brondsemcreate