classification
Title: zipfile: invalid link
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.7, Python 3.6, Python 3.5
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: docs@python Nosy List: berker.peksag, docs@python, lucasmus, serhiy.storchaka, terry.reedy
Priority: normal Keywords:

Created on 2017-02-03 09:13 by lucasmus, last changed 2017-06-18 18:58 by serhiy.storchaka. This issue is now closed.

Messages (5)
msg286847 - (view) Author: Lucas Moeskops (lucasmus) Date: 2017-02-03 09:13
The ZipFile documentation shows a link to the PKZip Application Node. This link, with address "https://pkware.cachefly.net/webdocs/casestudies/APPNOTE.TXT" goes to a "Page Not Found" document.
msg286900 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-02-03 23:07
The Applicaton Note link in both the doc and here work for me with Firefox and Edge.
'''
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
    <head>
...'''
You must have been hit by a temporary glitch.
msg286905 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2017-02-04 04:30
> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">

I think that HTML output suggests that their server configuration is broken. If you look at further down the page there is this error message:

    <p>Something has triggered missing webpage on your
    website. This is the default 404 error page for
    <strong>nginx</strong> that is distributed with
    EPEL.  It is located
    <tt>/usr/share/nginx/html/404.html</tt></p>

And:

    $ curl -I https://pkware.cachefly.net/webdocs/casestudies/APPNOTE.TXT
    HTTP/1.1 404 Not Found
    ...

https://support.pkware.com/display/PKZIP/Application+Note+Archives might be a suitable alternative to the broken link. I'm adding Serhiy to nosy list since he knows a lot about the ZIP file format.
msg286909 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-02-04 05:36
https://support.pkware.com/display/PKZIP/Application+Note+Archives contains links to old versions of APPNOTE (the last is 6.3.3). But the actual version was at least 6.3.4 (I have a local copy).

All external links refer to http://www.pkware.com/documents/casestudies/APPNOTE.TXT. I think we should report a bug to PKWare.
msg296288 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-06-18 18:58
The link already is fixed.
History
Date User Action Args
2017-06-18 18:58:53serhiy.storchakasetstatus: open -> closed
resolution: out of date
messages: + msg296288

stage: needs patch -> resolved
2017-02-04 05:36:08serhiy.storchakasetmessages: + msg286909
2017-02-04 04:30:56berker.peksagsetstatus: closed -> open

resolution: not a bug -> (no value)

assignee: docs@python
stage: resolved -> needs patch
versions: + Python 3.5, Python 3.7
nosy: + docs@python, berker.peksag, serhiy.storchaka
messages: + msg286905
components: + Documentation
type: behavior
2017-02-03 23:07:55terry.reedysetstatus: open -> closed

nosy: + terry.reedy
messages: + msg286900

resolution: not a bug
stage: resolved
2017-02-03 09:13:14lucasmuscreate