classification
Title: Building Python fails on SunOS
Type: compile error Stage:
Components: Build Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: loewis, syraxes
Priority: normal Keywords:

Created on 2008-05-22 09:16 by syraxes, last changed 2008-05-27 18:38 by loewis. This issue is now closed.

Messages (7)
msg67183 - (view) Author: Adrian M (syraxes) Date: 2008-05-22 09:16
$ uname -a
SunOS ro1estw 5.9 Generic_117171-12 sun4u sparc SUNW,Sun-Fire-880

gcc 2.6.3   


When running ./configure I'm getting warnings like: 
configure: WARNING: curses.h: present but cannot be compiled
configure: WARNING: curses.h:     check for missing prerequisite headers?
configure: WARNING: curses.h: see the Autoconf documentation
configure: WARNING: curses.h:     section "Present But Cannot Be Compiled"
configure: WARNING: curses.h: proceeding with the preprocessor's result
configure: WARNING: curses.h: in the future, the compiler will take
precedence

This happens for many other headers as well (dlfcn.h, fcntl.h, and many
others  - i'll attach the whole list of messages). 

Then, the ./configure step ends with the following message :
checking size of int... configure: error: cannot compute sizeof (int)
msg67204 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-05-22 19:21
Why do you think this is a bug in Python?
msg67220 - (view) Author: Adrian M (syraxes) Date: 2008-05-23 07:33
Also, please check: http://bugs.python.org/issue1544306
(exactly the same issue that has just been closed because of the lack of
feedback from the original reporter)

Here is another (old) report referring to the very same issue happening
on Solaris:
http://bugs.python.org/issue1234473
(an issue that doesn't seem to be solved)

I have no idea whether this is a real "Python bug" or not. I'm just
reporting a build "issue" that I'm experiencing when trying to compile
python on this particular (non-typical) platform.

So, I have the access to this SunOS machine and the you (the Python
developers) have the knowledge. Let's just work together and try to
discover why the building process is not working out-of-the-box on
SunOS, rather that imply that it's not a real python bug.
msg67240 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-05-23 14:14
Please take a look at the config.log, and locate the lines

In file included from
/usr/GNU/lib/gcc-lib/sparc-sun-solaris2.4/2.6.3/include/time.h:90,
                 from /usr/include/sys/time.h:418,
                 from /usr/include/sys/termios.h:23,
                 from /usr/include/sys/termio.h:13,
                 from /usr/include/termio.h:13,
                 from
/usr/GNU/lib/gcc-lib/sparc-sun-solaris2.4/2.6.3/include/curses.h:48,
                 from conftest.c:47:
/usr/include/sys/siginfo.h:74: parse error before `pthread_attr_t'

Then please take a look at line 90 of
/usr/GNU/lib/gcc-lib/sparc-sun-solaris2.4/2.6.3/include/time.h
and confirm that it indeed includes siginfo.h at that line.

Then please compare /usr/include/time.h with
/usr/GNU/lib/gcc-lib/sparc-sun-solaris2.4/2.6.3/include/time.h
and report any differences that you see.

To me, it seems that your compiler's header files don't match your
system's header files. This is not surprising, as gcc 2.6.3 was released
in 1994, years before Solaris 9 was released; your gcc was build for
Solaris 2.4. You probably need to run fixincludes again (i.e. rebuild
gcc for your system), or install a newer version of gcc entirely.
msg67407 - (view) Author: Adrian M (syraxes) Date: 2008-05-27 12:31
Thanks for the tip, Martin:    on this server there are two gcc's
installed:  2.6.3 in /usr/GNU   and  3.4.2  in /usr/local.  

After setting the PATH to point to /usr/local/bin the 'configure' and
the 'make'  steps have completed successfully .

Now there is just one more problem: 
$ make install
Creating directory /home/am/usr/bin
mkdir: Failed to make directory "/home/am"; Operation not applicable
mkdir: Failed to make directory "/home/am/usr"; No such file or directory
mkdir: Failed to make directory "/home/am/usr/bin"; No such file or
directory
Creating directory /home/am/usr/lib
mkdir: Failed to make directory "/home/am"; Operation not applicable
mkdir: Failed to make directory "/home/am/usr"; No such file or directory
mkdir: Failed to make directory "/home/am/usr/lib"; No such file or
directory
make: *** [altbininstall] Error 2
msg67408 - (view) Author: Adrian M (syraxes) Date: 2008-05-27 12:40
Problem solved ! 

(the make install problem was because i was trying to use a wrong
--prefix directory)
msg67424 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-05-27 18:38
Closing the report as "invalid" then (and I strongly recommend to remove
gcc 2.6.3 right away. It obviously cannot be used to compile software on
your system).
History
Date User Action Args
2008-05-27 18:38:49loewissetstatus: open -> closed
resolution: not a bug
messages: + msg67424
2008-05-27 12:40:14syraxessetmessages: + msg67408
2008-05-27 12:38:17syraxessetfiles: - config_logs.zip
2008-05-27 12:31:45syraxessetmessages: + msg67407
2008-05-23 14:14:47loewissetmessages: + msg67240
2008-05-23 07:33:28syraxessetmessages: + msg67220
2008-05-22 19:21:13loewissetnosy: + loewis
messages: + msg67204
2008-05-22 09:16:52syraxescreate